Bug 811852 - Exception on conductor when tried to create a new image from wrong URL
Exception on conductor when tried to create a new image from wrong URL
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jozef Zigmund
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 02:41 EDT by Rehana
Modified: 2012-12-04 10:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When trying to create a new image or Application Blueprint in Conductor using a wrong URL, the wrong error message was returned. This bug fix updates application_controller.rb to display the appropriate error message: "Provided URL is not valid"
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:03:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss1 (180.69 KB, image/png)
2012-04-12 02:41 EDT, Rehana
no flags Details
Rails log (10.24 KB, text/plain)
2012-04-12 02:42 EDT, Rehana
no flags Details
validation (45.50 KB, image/png)
2012-09-20 08:38 EDT, Aziza Karol
no flags Details

  None (edit)
Description Rehana 2012-04-12 02:41:16 EDT
Created attachment 576967 [details]
ss1

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.login to conductor
2.Go to "clouds" --> new image --> from URL
3.Issue the URL with a semicolon instead of colon 

ex:http;//hp-z600-01.rhts.eng.bos.redhat.com/rhel62vmtools
  
Actual results:

got an error on conductor:"undefined method `request_uri' for #<URI::Generic:0x7fb611605c60>" (PFA: rails.log, ss1.png) 

Expected results:
should show appropriate error message

Additional info:

rpm -qa| grep aeolus
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
Comment 1 Rehana 2012-04-12 02:42:00 EDT
Created attachment 576969 [details]
Rails log
Comment 2 Rehana 2012-04-12 08:34:55 EDT
This is also occurring when tried to create application blueprint with same url
http;//hostname/filename
Comment 3 Jozef Zigmund 2012-08-23 11:57:27 EDT
Bugfix has been sent to the aeolus-devel mailing list:

https://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/012285.html
Comment 4 Jozef Zigmund 2012-09-06 12:17:49 EDT
Bugfix pushed in master with commit #90d951e4ae2a3eff3e8d5768b5927ef027a4b805 and to 1.1 branch with commit # ce955791f387d7f90f662448a152d6895ff9c4c1
Comment 5 Steve Linabery 2012-09-07 17:50:16 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 7 Aziza Karol 2012-09-20 08:38:03 EDT
"Provided URL is not valid http;//hp-z600-01.rhts.eng.bos.redhat.com/rhel62vmtools"  is displayed if an image is created with an invalid url.
see attached screenshot.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
Comment 8 Aziza Karol 2012-09-20 08:38:45 EDT
Created attachment 614875 [details]
validation
Comment 10 errata-xmlrpc 2012-12-04 10:03:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.