Bug 811853 - No component item in editing case UI
No component item in editing case UI
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: June Zhang
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 02:43 EDT by Shaolong Hu
Modified: 2015-11-08 19:50 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 02:53:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-04-12 02:43:38 EDT
Description of problem:
-----------------------
when create a case in tcms, we need choose a component, if we leave it blank, we still can create the case successfully, but when we edit the case and want to add or change the component, no corresponding item in editing UI.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jin Zhao 2012-04-12 02:53:21 EDT
Thanks for your report.

This is not a bug, You can define product component in admin. Steps as following:

1. Click Admin -> Management -> Component , Link to https://tcms.engineering.redhat.com/admin/management/component/

2. Filter by product which you want to add or update components.

3. Click "Add component" can add component for this product
   Click existing component ID can edit it.

Please have a try, any problem feel free to contact us.

Thanks
Comment 2 Jin Zhao 2012-04-12 03:11:33 EDT
Sorry, You can edit component via two methods.

First, Select test cases which you want to edit in test plan , Click "component" then edit .

Second, Enter to test case detail page , Click "component" tab to edit .
Comment 3 Shaolong Hu 2012-04-12 03:12:46 EDT
OK,talking with Jin Zhao, there is a workaround, and it works fine.

Note You need to log in before you can comment on or make changes to this bug.