Bug 811856 - Add features in build: lvm-snapshot, btrfs-snapshot, unit testing
Add features in build: lvm-snapshot, btrfs-snapshot, unit testing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: schroot (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zach Carter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 02:46 EDT by Oron Peled
Modified: 2012-06-13 17:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 21:48:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2012-04-12 02:46:46 EDT
Description of problem:

current schroot has no 'lvm-snapshot' support

Steps to Reproduce:
1. create an 'lvm-snapshot' configuration file:
       [sid-snapshot]
       type=lvm-snapshot
       description=Debian unstable LVM snapshot
       priority=3
       groups=sbuild
       users=rleigh
       source-root-users=rleigh
       source-root-groups=admin
       device=/dev/hda_vg/sid_chroot
       mount-options=-o atime,sync,user_xattr
       lvm-snapshot-options=--size 2G

2. run 'schroot -l'
  
Additional info:

The reason is very simple. The schroot configure script check during
build if both lvcreate/lvremove exists. If not, than it compiles
the code without 'lvm-snapshot' support.

Suggested fix:
 * Add a BuildRequires: lvm2
 * I don't currently use btrfs, but 'btrfs-snapshot' is also turned off
   because of similar test. Maybe it's time to add this support as well.
Comment 1 Oron Peled 2012-04-12 05:05:42 EDT
 * Note: bug #600636 comment #4 contains a minor patch to lockdev.
         With this patch, schroot finally can be used by non-root users
         on 'lvm-snapshot' schroots.

 * Supporting also btrfs-snapshot:
   - Add BR: btrfs-progs enable this feature in schroot

   - Build tested, but cannot use this    feature now, since I don't have
     any btrfs filesystems.

 * Support unit testing:
   - Add BR: cppunit-devel

   - Add BR: fakeroot

   - Add to the .spec file:
      %check
      fakeroot make check

   - The unit testing works either with/without the LVM and BTRFS changes
     (without them, these features simply runs 0 tests)
Comment 2 Zach Carter 2012-04-12 12:56:55 EDT
New rawhide build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3985793

%changelog
* Thu Apr 12 2012 Zach Carter <z.carter@f5.com> - 1.4.25-1
- New upstream version (removes need for gcc47-patch)
- Add BR to enable unit tests, lvm snapshot, btrfs snapshot support (BZ 811856)
- Add schroot-test-sbuild-util-path.patch
Comment 3 Fedora Update System 2012-05-10 14:40:57 EDT
schroot-1.4.25-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/schroot-1.4.25-1.fc17
Comment 4 Fedora Update System 2012-05-10 16:12:57 EDT
schroot-1.4.25-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/schroot-1.4.25-3.fc16
Comment 5 Oron Peled 2012-05-10 17:09:15 EDT
Browsing the build.log, there is a minor man-pages build bug.
Example (around line 678 of the log):
   make[2]: [schroot-setup.5] Error 127 (ignored)
   /bin/sh: I: command not found

From looking in the man/Makefile.am, it seems the problem is caused
by missing definition of $(SOELIM) which should be found by ./configure.

The configure.ac indeed looks for SOELIM and looking again in the build.log
shows it did not find the soelim(1) program in the mock chroot.

On Fedora, soelim(1) is provided by groff which should be added to the BR of the package.
Comment 6 Fedora Update System 2012-05-11 06:29:10 EDT
Package schroot-1.4.25-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing schroot-1.4.25-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7690/schroot-1.4.25-3.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-11 12:38:05 EDT
schroot-1.4.25-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/schroot-1.4.25-4.fc16
Comment 8 Fedora Update System 2012-05-25 13:34:13 EDT
schroot-1.4.25-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/schroot-1.4.25-7.fc17
Comment 9 Fedora Update System 2012-05-26 21:48:42 EDT
schroot-1.4.25-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-06-13 17:36:06 EDT
schroot-1.4.25-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.