Bug 81187 - The installer crashed while (or just after) performing the post scripts
Summary: The installer crashed while (or just after) performing the post scripts
Status: CLOSED DUPLICATE of bug 81091
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-06 16:53 UTC by Daniel Veillard
Modified: 2008-01-17 17:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The anaconda dump (81.53 KB, text/plain)
2003-01-06 16:55 UTC, Daniel Veillard
no flags Details

Description Daniel Veillard 2003-01-06 16:53:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
The installed crashed when installing on the IBM 600E laptop
Last thing I remember was the slide bar for the postinstall script
moving ...
Fresh install 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Installing Phoebe
2.
3.
    

Actual Results:  installer crashed

Expected Results:  installer to not crash

Additional info:

I save the dump to a floppy

Comment 1 Daniel Veillard 2003-01-06 16:55:41 UTC
Created attachment 89161 [details]
The anaconda dump

Seems it's a signal handler for a mouse click which is not handled 
possibly by the rule widget indicating the progresses on the post-install
scripts ...

Comment 2 Daniel Veillard 2003-01-08 20:01:17 UTC
I reran the same installation steps, same configuration, same
parameters, but refrained from doing any keybard or mouse
interraction and watching closely the post-install step and
all went fine. So I assume I pressed the wrong button at
the wrong spot and at the wrong time. This is not easilly repeatable

Daniel

Comment 3 Michael Fulbright 2003-01-08 20:55:25 UTC
Could you please retry with beta 3 (Phoebe)?

Comment 4 Daniel Veillard 2003-01-08 23:44:32 UTC
It was with 8.0.92 beta 3 (Phoebe)

Comment 5 Jeremy Katz 2003-01-10 06:00:22 UTC
Arjan -- this smells like it might be a kernel problem.  

We have /proc/bus/usb initially mounted in the install system environment.  It
gets unmounted and we then remount usbdevfs as /proc/bus/usb inside the chroot.
 Run kudzu inside the chroot.  Then, when we go to unmount it later, we get EINVAL.

I've gone ahead and put some insulation in anaconda to stop this from being a
problem for us, so if you don't care, feel free to close, but thought it might
potentially be interesting.  



Comment 6 Pete Zaitcev 2003-02-18 00:40:40 UTC
Actually, I think I fixed it somewhere 2.4.20-2.21, see bug 81091.
I am not duping this bug because it tracks installer that Jeremy mentioned.


Comment 7 Jeremy Katz 2003-02-18 01:07:41 UTC
Looks dupable to me (like I said, I added a workaround to anaconda also :)

*** This bug has been marked as a duplicate of 81091 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.