Bug 811884 - Stack dump trying to list repositories of an exercised RHUI deployment
Stack dump trying to list repositories of an exercised RHUI deployment
Status: CLOSED WONTFIX
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: 2.1.x
Assigned To: James Slagle
mkovacik
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 04:48 EDT by mkovacik
Modified: 2016-03-29 13:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 13:46:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkovacik 2012-04-12 04:48:41 EDT
Description of problem:
While trying to set up a proxy configuration I brought a KVM RHUI deployment to a stack-dumping state---see the Additional info paragraph. This happens while getting the list of managed repositories via both the pulp-admin and rhui-manager tools. The actions done include modifications of /etc/rhui/rhui-tools.conf and /etc/pulp/pulp.conf files and few restarts of the pulp-server service as well as changing iptables configuration to disable outgoing https traffic. Here, after some gofer-related communication errors, outgoing loop-back https traffic was enabled eventually.  

Version-Release number of selected component (if applicable):
Upgrade from 2.0.1 to 2.0.3; RHEL-6.2-RHUI-2.0.3-20120322.0-Server-x86_64-DVD1.iso

How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:
A stack dump trying to list managed repositories 

Expected results:
A list of repositories depicted

Additional info:
### SCREEN LOG, ERROR DETAILS

[root@dhcp-31-127 ~]# pulp-admin -u admin -p admin repo list
error:  operation failed: IndexError: list index out of range
[root@dhcp-31-127 ~]# less .rhui/rhui.log 

Unexpected error caught at the shell level
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhui/tools/shell.py", line 87, in safe_listen
    self.listen(clear=first_run)
  File "/usr/lib/python2.6/site-packages/rhui/tools/shell.py", line 113, in listen
    Shell.listen(self)
  File "/usr/lib/python2.6/site-packages/rhui/common/shell.py", line 191, in listen
    item.func(*args, **item.kwargs)
  File "/usr/lib/python2.6/site-packages/rhui/tools/screens/repo.py", line 55, in list
    redhat_repos = self.pulp.redhat_repo_list()
  File "/usr/lib/python2.6/site-packages/rhui/tools/pulp_api.py", line 164, in redhat_repo_list
    raise e
ServerRequestError: (500, u'IndexError: list index out of range', u'Traceback (most recent call last):\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 48, in report_error\n    return method(self, *args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/s
erver/webservices/controllers/decorators.py", line 127, in _auth_decorator\n    value = method(self, *args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 155, in _query_decortator\n    return method(self, *args, **kwargs)\n  File "/usr/lib/python2.6
/site-packages/pulp/server/webservices/controllers/repositories.py", line 241, in GET\n    repo[\'uri\'] = serialization.repo.v1_uri(repo)\n  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/serialization/repo.py", line 63, in v1_uri\n    return cds[\'next_permutation\'][0]')
Comment 1 wes hayutin 2012-08-09 09:41:33 EDT
no steps for repro.. kicking out to 2.1.1
Comment 2 dgao 2013-11-05 11:46:29 EST
Not able to reproduce this issue, punting to future release of RHUI.
Comment 5 Chris Duryee 2016-03-29 13:46:14 EDT
bug has not been updated in awhile, closing out. Please re-open if it's still an issue.

Note You need to log in before you can comment on or make changes to this bug.