Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 811900 - [abrt] telepathy-butterfly-0.5.15-4.fc16: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/mikethepsych_40blueyonder_2eco_2euk at 0x2dadf90>
Summary: [abrt] telepathy-butterfly-0.5.15-4.fc16: connmgr.py:65:disconnected:KeyError...
Keywords:
Status: CLOSED DUPLICATE of bug 691209
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:aef7227c6f22113aecd1f897eb6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-12 09:35 UTC by Mike Parker
Modified: 2012-04-17 09:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-17 09:23:55 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Parker 2012-04-12 09:35:39 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         3.3.1-3.fc16.x86_64
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/mikethepsych_40blueyonder_2eco_2euk at 0x2dadf90>
time:           Thu 12 Apr 2012 10:13:56 AM BST
uid:            500
username:       Mike

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/mikethepsych_40blueyonder_2eco_2euk at 0x2dadf90>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 438, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 330, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/mikethepsych_40blueyonder_2eco_2euk at 0x2dadf90>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x2d438d0>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/mikethepsych_40blueyonder_2eco_2euk at 0x2dadf90>

smolt_data:
:
:
:General
:=================================
:UUID: f00f0634-0c27-4eb4-a078-81a32ad130ae
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4000.42
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 Processor 3200+
:CPU Stepping: 8
:CPU Family: 15
:CPU Model Num: 4
:Number of CPUs: 1
:CPU Speed: 1999
:System Memory: 2004
:System Swap: 4031
:Vendor: MSI
:System: MS-6702 00A
:Form factor: Desktop
:Kernel: 3.3.1-3.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Terra.1680.1050
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5361:12032:5147:36232) pci, None, SIMPLE, HSF 56k HSFi Modem
:(4358:12839:5218:12839) pci, None, PCI/ISA, VT8237 ISA bridge [KT600/K8T800/K8T890 South]
:(4358:12548:5218:28704) pci, ehci_hcd, USB, K8T NEO 2 motherboard
:(4358:12344:5218:28704) pci, uhci_hcd, USB, K8T NEO 2 motherboard
:(4358:12344:5218:28704) pci, uhci_hcd, USB, K8T NEO 2 motherboard
:(4358:12344:5218:28704) pci, uhci_hcd, USB, K8T NEO 2 motherboard
:(4358:12344:5218:28704) pci, uhci_hcd, USB, K8T NEO 2 motherboard
:(4358:12680:4358:12824) pci, agpgart-amd64, HOST/PCI, VT8385 [K8T800 AGP] Host Bridge
:(4358:45448:0:0) pci, None, PCI/PCI, VT8237 PCI bridge [K8T800/K8T890 South]
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, amd64_edac, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4358:12377:5218:128) pci, snd_via82xx, MULTIMEDIA_AUDIO, K8T NEO 2 motherboard
:(4098:20072:4098:3) pci, None, VIDEO, Radeon R350 [Radeon 9800 Pro] (Secondary)
:(4098:20040:4098:2) pci, radeon, VIDEO, Radeon R350 [Radeon 9800 Pro]
:(5772:19:4486:14867) pci, ath5k, ETHERNET, AirPlus DWL-G520 Wireless PCI Adapter (rev. B)
:(4186:13171:5218:28718) pci, sata_promise, RAID, K8T NEO FIS2R motherboard
:(4358:12356:5218:28717) pci, firewire_ohci, FIREWIRE, K8T NEO 2 motherboard
:(4358:12617:5218:28704) pci, sata_via, STORAGE, K8T Neo 2 Motherboard
:(4358:1393:5218:28704) pci, pata_via, STORAGE, K8T NEO 2 motherboard
:(4332:33129:5218:28716) pci, r8169, ETHERNET, K8T NEO 2 motherboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_turnip-lv_root / ext4 4096 4096 13092922 6072180 5941141 3276800 3058251 3058251
:/dev/sdb1 WITHHELD fuseblk 4096 4096 18749999 9825629 9825629 39531892 39370156 39370156
:/dev/sdb2 /boot ext4 1024 1024 508745 411758 386158 128016 127780 127780
:/dev/mapper/vg_turnip-lv_home /home ext4 4096 4096 5120268 4552503 4295684 1286144 1272668 1272668
:

Comment 1 Mike Parker 2012-04-17 09:21:19 UTC
It looks like this error occurs when I have LAN but not WAN/WWW access (i.e. when my ISP is down but my LAN is still available).

Comment 2 Mike Parker 2012-04-17 09:23:55 UTC

*** This bug has been marked as a duplicate of bug 691209 ***


Note You need to log in before you can comment on or make changes to this bug.