Bug 811921 - virt-manager should depend on libgnome-keyring not on gnome-keyring
virt-manager should depend on libgnome-keyring not on gnome-keyring
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 06:37 EDT by Stef Walter
Modified: 2012-10-24 13:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: virt-manager-0.9.1-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 09:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager should depend on libgnome-keyring not on gnome-keyring (1.44 KB, patch)
2012-04-12 06:37 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Stef Walter 2012-04-12 06:37:22 EDT
libgnome-keyring is the client side component.
Comment 1 Stef Walter 2012-04-12 06:37:27 EDT
Created attachment 577030 [details]
virt-manager should depend on libgnome-keyring not on gnome-keyring

 * libgnome-keyring is the client library
 * No need to specify version since all versions of libgnome-keyring
   out of gnome-keyring after the version that virt-manager
   expects.
Comment 2 Fedora Update System 2012-04-25 09:56:50 EDT
virt-manager-0.9.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.1-3.fc17
Comment 3 Fedora Update System 2012-04-26 15:26:31 EDT
Package virt-manager-0.9.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6651/virt-manager-0.9.1-3.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-05-02 16:52:03 EDT
virt-manager-0.9.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Martin Kho 2012-10-15 04:01:47 EDT
Hi,

Sorry, but this issue is back in version 0.9.4-1.

[martin@localhost ~]$ rpm -q --requires virt-manager
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
GConf2
GConf2
GConf2
dbus-python >= 0.61
dbus-x11
desktop-file-utils
desktop-file-utils
gnome-keyring >= 0.4.9
gnome-python2-gconf >= 1.99.11-7
gnome-python2-gnomekeyring >= 2.15.4
gtk-vnc-python >= 0.3.8
libvirt-python >= 0.7.0
libxml2-python >= 2.6.23
pygtk2 >= 1.99.12-6
python-virtinst >= 0.600.3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
scrollkeeper
spice-gtk-python
virt-manager-common = 0.9.4-1.fc18.1
vte >= 0.12.2
rpmlib(PayloadIsXz) <= 5.2-1

Martin Kho
Comment 6 Cole Robinson 2012-10-19 12:12:16 EDT
Whoops, yeah this is busted.
Comment 7 Cole Robinson 2012-10-24 09:12:35 EDT
Fixed in virt-manager-0.9.4-2.fc19
Comment 8 Martin Kho 2012-10-24 10:45:00 EDT
Hi Cole,

virt-manager still fetches gnome-keyring as a dependency. This is caused gnome-python2-gnomekeyring.

byResolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.9.4-2.fc18 will be installed
--> Processing Dependency: gnome-python2-gnomekeyring >= 2.15.4 for package: virt-manager-0.9.4-2.fc18.noarch
---> Package virt-manager-common.noarch 0:0.9.4-2.fc18 will be installed
--> Running transaction check
---> Package gnome-python2-gnomekeyring.x86_64 0:2.32.0-12.fc18 will be installed
--> Processing Dependency: gnome-keyring >= 0.5.0 for package: gnome-python2-gnomekeyring-2.32.0-12.fc18.x86_64
--> Running transaction check
---> Package gnome-keyring.x86_64 0:3.6.1-1.fc18 will be installed
--> Finished Dependency Resolution

in the spec file:
# These two are just the oldest version tested
Requires: pygtk2 >= 1.99.12-6
Requires: gnome-python2-gconf >= 1.99.11-7
# This version not strictly required: virt-manager should work with older,
# however varying amounts of functionality will not be enabled.

HTH,

Martin Kho
Comment 9 Cole Robinson 2012-10-24 13:00:29 EDT
Martin, that's expected I think, since we still need gnome-python2-gnomekeyring. virt-manager can't use gobject introspection because it conflicts with pygtk2 AIUI.

We will be porting to soon though.
Comment 10 Martin Kho 2012-10-24 13:57:29 EDT
Hi Cole,

Thanks for your information. I thought, I just let you know. Of cource this is not a show stopper. :-) And success with the port.

Martin Kho

Note You need to log in before you can comment on or make changes to this bug.