Bug 811970 - mkdir .landfill succeeds on mountpoint but cd , ls, rmdir fails on that directory
mkdir .landfill succeeds on mountpoint but cd , ls, rmdir fails on that direc...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 08:36 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test cases for old_trash to new_trash .landfill -> .glusterfs/landfill (2.07 KB, application/x-shellscript)
2012-05-31 14:50 EDT, Pranith Kumar K
no flags Details

  None (edit)
Description M S Vishwanath Bhat 2012-04-12 08:36:26 EDT
Description of problem:
.landfill is a afr trash directory. Not sure if users are allowed to create .landfill dir. But if it is allowed rmdir, ls and cd should also be allowed. But mkdir .landfill succeeds, but ls -a doesn't list  it. cd .landfill fails. and rmdir fails saying no such file or dir. But  mkdir .landfill again and it complains saying file already exists.

Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa34

How reproducible:
Often

Steps to Reproduce:
1. Create and start a replicated volume. And mount the volume.
[root@QA-28 mnt]# mkdir .landfill
[root@QA-28 mnt]# echo $?
0
[root@QA-28 mnt]# ls -a
.  ..
[root@QA-28 mnt]# cd .landfill
bash: cd: .landfill: No such file or directory
[root@QA-28 mnt]# rmdir .landfill
rmdir: failed to remove `.landfill': No such file or directory
[root@QA-28 mnt]# mkdir .landfill
mkdir: cannot create directory `.landfill': File exists
[root@QA-28 mnt]# 


Expected results:
Either user's shouldn't be allowed to create .landfill or if allowed it should be accessible.
Comment 1 Pranith Kumar K 2012-05-31 14:50:33 EDT
Created attachment 588168 [details]
Test cases for old_trash to new_trash .landfill -> .glusterfs/landfill

The issue happens because the .landfill dir is trash dir for AFR. Attached are the test cases for moving it into .glusterfs
Comment 2 M S Vishwanath Bhat 2012-06-06 04:05:34 EDT
Patch present only in master. Not in release-3.3

Note You need to log in before you can comment on or make changes to this bug.