This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 81200 - Kbabel fails on paste
Kbabel fails on paste
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdesdk (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 81198 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-06 13:15 EST by Nikos Charonitakis
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xml file requested (77.96 KB, text/xml)
2003-02-01 10:34 EST, Nikos Charonitakis
no flags Details

  None (edit)
Description Nikos Charonitakis 2003-01-06 13:15:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; el-gr; rv:1.0.1) Gecko/20021003

Description of problem:
I tried to paste some translated strings from an xml file
opened with gedit but it pastes only codes not actual characters.
Then i change the file from xxx.xml to xxx.txt and open it
with mozilla browser.
Now it pastes the strings but after one or two times using
the paste function (from mozilla to Kbabel) Kbabel crashes...

here is the backtrace

no debugging symbols found)...[New Thread 8192 (LWP 2001)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f29c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406bf1b5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x420749f9 in free () from /lib/i686/libc.so.6
#6  0x40cd7853 in operator delete(void*) (ptr=0xfffffe00)
    at ../../../../libstdc++-v3/libsupc++/del_op.cc:39
#7  0x40cd787f in operator delete[](void*) (ptr=0xfffffe00)
    at ../../../../libstdc++-v3/libsupc++/del_opv.cc:36
#8  0x40c4efe8 in QStringData::deleteSelf() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#9  0x4099c3b5 in QFont::~QFont() () from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#10 0x40a331b2 in QTextFormat::width(QChar const&) const ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x40a35126 in QTextString::width(int) const ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x40a3e916 in QTextFormatterBreakWords::format(QTextDocument*,
QTextParagraph*, int, QMap<int, QTextLineStart*> const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x40a36ea1 in QTextParagraph::format(int, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#14 0x40b16f79 in QTextEdit::formatMore() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x40b17772 in QTextEdit::insert(QString const&, bool, bool, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x40086a37 in MyMultiLineEdit::insert(QString const&, bool, bool, bool) ()
   from /usr/lib/libkbabel.so.1
#17 0x40b1ceea in QTextEdit::pasteSubType(QCString const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#18 0x40b184eb in QTextEdit::paste() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x40087532 in MyMultiLineEdit::paste() () from /usr/lib/libkbabel.so.1
#20 0x40b11cd3 in QTextEdit::keyPressEvent(QKeyEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#21 0x4008b48a in MsgMultiLineEdit::keyPressEvent(QKeyEvent*) ()
   from /usr/lib/libkbabel.so.1
#22 0x40a113cc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#23 0x40b117dd in QTextEdit::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#24 0x40988c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#25 0x40988540 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#26 0x406539a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#27 0x4092e58d in QETWidget::translateKeyEvent(_XEvent const*, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#28 0x409299e5 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#29 0x4092952f in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#30 0x4098a280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#31 0x4092902d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#32 0x0804ca9a in main ()
#33 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.described above
2.
3.
    

Actual Results:  crash

Expected Results:  work paste fuction

Additional info:
Comment 1 Michael Lee Yohe 2003-01-06 13:33:55 EST
Duplicate of Bug 81198
Comment 2 Ngo Than 2003-02-01 05:15:36 EST
*** Bug 81198 has been marked as a duplicate of this bug. ***
Comment 3 Ngo Than 2003-02-01 05:16:28 EST
could you please attach your xml file, which causes this problem? thanks
Comment 4 Nikos Charonitakis 2003-02-01 10:34:16 EST
Created attachment 89764 [details]
xml file requested
Comment 5 Bill Nottingham 2006-10-18 14:32:54 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.