This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 812088 - XChat unable to connect to freenode
XChat unable to connect to freenode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 13:47 EDT by Ryan
Modified: 2012-04-16 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 12:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan 2012-04-12 13:47:37 EDT
Description of problem:

prior to updates in the last week I was able to connect
without issue, but since that time it seems to be inserting rubbish characters
into the username when connecting to freenode (e.g. ~) constantly looping on
the following with each different freenode server:

* Looking up irc.freenode.net
* Connecting to chat.freenode.net (82.96.64.4) port 8002...
* Connected. Now logging in...
* *** Looking up your hostname...
* *** Checking Ident
* *** Found your hostname
* *** No Ident response
* *** Your username is invalid. Please make sure that your username contains
only alphanumeric characters.
* Closing Link: <my ip address> (Invalid username [~_xxx]) [where xxx is my
username]
* Disconnected (Remote host closed socket).
 Cycling to next server in FreeNode...
* Disconnected ().

It reports "username" problems whenever I connect to any IRC server with xchat. Funnily enough, I can connect via konversation, and then re-connect xchat and
it works (except it detects my username in use). 

Version-Release number of selected component (if applicable):

xchat - 2.8.8
Fedora 16 - 3.3.1-3 Kernel x86_64

How reproducible:

easily

Steps to Reproduce:
1. log into xchat
2. connect to freenode
3. watch the loop
  
Actual results:

constant loop stating username is not valid

Expected results:

connection to IRC server

Additional info:

I have tried removing my personal preferences and re-connecting to no avail..(e.g. deleted the .xchat2 folder in my profile). I also changed the character sets on the server network list in an attempt to rectify the issue. This worked prior to some updates occuring around the same time 3.3.1-3 kernel was released
Comment 1 Ryan 2012-04-16 12:46:40 EDT
Issue resolved by putting ident information into real name/username, caused by attempt to put username into real name/username.

Note You need to log in before you can comment on or make changes to this bug.