Bug 81211 - After boot diskette creation fails, all subsequent attempts fail too
After boot diskette creation fails, all subsequent attempts fail too
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-06 15:11 EST by Miloslav Trmac
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:50:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2003-01-06 15:11:09 EST
Version-Release number of selected component (if applicable):
anaconda-8.0.92-8

How Reproducible:
haven't tried from 1., but did from .2

Steps to Reproduce:
1.When asked to create a boot diskette, insert one with bad blocks
2.Replace it with a good diskette
3.Try again
    
Actual results:
After an error box about creation of the diskette (with very general
message and no error output on any of the VTs AFAICS, by the way),
all subsequent attempts to create a boot diskette fail almost
immediately (just about half a second of floppy head seeking).
Comment 1 Bill Nottingham 2003-01-06 17:54:39 EST
Hm, are we unmounting the image correctly in these cases?
Comment 2 Jeremy Katz 2003-01-08 16:05:18 EST
Looks like we are, and I haven't seen this (and I have tried with bad floppies).
 Do you get any error messages on tty4?  
Comment 3 Miloslav Trmac 2003-01-14 07:05:00 EST
Reproduced (badblocks shows bad blocks from sector 8 or 12, not from
the first) on a very minimal install (minimal and then deselect all
packages in individual package selection) using Czech language.

No errors anywhere, except for a dump of 3 lines (blocks for
kernel, initrd,... IIRC). These lines get added every time,
but the floppy head just moves a few times and creation immediately
fails.
Comment 4 Jeremy Katz 2003-02-05 17:55:08 EST
This should be happier with the changes to mkbootdisk and the rest of the boot
disk creation code.
Comment 5 Brent Fox 2003-05-25 10:50:55 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.