Bug 812118 - abrtd installed and running by default but no plugin enabled
abrtd installed and running by default but no plugin enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 15:24 EDT by Stijn Hoop
Modified: 2012-08-09 18:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: abrt-2.0.10-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:23:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stijn Hoop 2012-04-12 15:24:37 EDT
Description of problem:

My X11 crashed but unfortunately abrt did not capture any core file. This seems to be because a default installation of F17 Beta 3 does not enable any of the abrt plugins. It just enables the abrtd main service. Is there a point in running abrtd without the other plugins?

$ systemctl list-unit-files | grep abrt
abrt-ccpp.service                           disabled
abrt-oops.service                           disabled
abrt-vmcore.service                         disabled
abrtd.service                               enabled 

Installation of F17 Beta 3 was done using USB key, not an upgrade.

$ rpm -qa abrt\*
abrt-2.0.10-1.fc17.x86_64
abrt-dbus-2.0.10-1.fc17.x86_64
abrt-addon-vmcore-2.0.10-1.fc17.x86_64
abrt-addon-ccpp-2.0.10-1.fc17.x86_64
abrt-gui-2.0.10-1.fc17.x86_64
abrt-desktop-2.0.10-1.fc17.x86_64
abrt-libs-2.0.10-1.fc17.x86_64
abrt-addon-kerneloops-2.0.10-1.fc17.x86_64
abrt-addon-python-2.0.10-1.fc17.x86_64
Comment 1 Jiri Moskovcak 2012-08-09 18:23:28 EDT
This should be already fixed. All ABRT plugin which are installed by default (python, C, kernel, xorg) are enabled by default. The problem might be, that it's actually not started until the next reboot (or until does it manually).

snippet from the spec file:

if [ $1 -eq 1 ]; then
    # (see explanation in addon-ccpp section)
%if %{with systemd}
    # Enable (but don't start) the units by default
    /bin/systemctl enable abrt-xorg.service >/dev/null 2>&1 || :
%else
    if /sbin/chkconfig abrtd >/dev/null 2>&1; then
        /sbin/chkconfig --add abrt-xorg
    fi
%endif


Fixed since abrt-2.0.10-3

Note You need to log in before you can comment on or make changes to this bug.