Bug 812122 - Sudo commands are case-insensitive
Sudo commands are case-insensitive
Status: CLOSED DUPLICATE of bug 800544
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Prpic
IDM QE LIST
:
Depends On: 800544
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 15:46 EDT by Rob Crittenden
Modified: 2013-02-21 04:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Identity Management sudo commands are not case sensitive. For example, executing the following commands will result in the latter one failing due to the case insensitivity: ~]$ ipa sudocmd-add /usr/bin/X ⋮ ~]$ ipa sudocmd-add /usr/bin/x ipa: ERROR: sudo command with name "/usr/bin/x" already exists
Story Points: ---
Clone Of: 800544
Environment:
Last Closed: 2013-02-21 04:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2012-04-12 15:46:48 EDT
We need to technote this.

Because the sudo command is in the dn of the entry it is not case sensitive.

+++ This bug was initially created as a clone of Bug #800544 +++

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2482

{{{
    $ ipa sudocmd-add /usr/bin/X
    -------------------------------
    Added Sudo Command "/usr/bin/X"
    -------------------------------
      Sudo Command: /usr/bin/X
     
    $ ipa sudocmd-show /usr/bin/x
      Sudo Command: /usr/bin/X
     
    pviktori@vm-140:~/freeipa$ ipa sudocmd-add /usr/bin/x
    ipa: ERROR: sudo command with name "/usr/bin/x" already exists
     
    $ ipa sudocmdgroup-add group1 --desc=blabla
    ---------------------------------
    Added Sudo Command Group "group1"
    ---------------------------------
      Sudo Command Group: group1
      Description: blabla
     
    $ ipa sudocmdgroup-add-member group1 --sudocmds=/usr/bin/X
      Sudo Command Group: group1
      Description: blabla
      Member Sudo commands: /usr/bin/x
    -------------------------
    Number of members added 1
    -------------------------
     
    $ ipa sudocmd-del /usr/bin/x
    ---------------------------------
    Deleted Sudo Command "/usr/bin/x"
    ---------------------------------
     
    $ ipa sudocmdgroup-show group1
      Sudo Command Group: group1
      Description: blabla 
}}}
Comment 2 Martin Prpic 2012-04-13 09:40:11 EDT
Added to 6.3 Technical Notes
Comment 3 Martin Prpic 2012-04-13 09:40:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Identity Management sudo commands are not case sensitive. For example, executing the following commands will result in the latter one failing due to the case insensitivity:

    ~]$ ipa sudocmd-add /usr/bin/X
    ⋮
    ~]$ ipa sudocmd-add /usr/bin/x
    ipa: ERROR: sudo command with name "/usr/bin/x" already exists
Comment 5 Martin Kosek 2013-02-21 04:17:53 EST

*** This bug has been marked as a duplicate of bug 800544 ***

Note You need to log in before you can comment on or make changes to this bug.