Bug 812172 - sorting order for repos is not the same in Provider and Sync Management Views
sorting order for repos is not the same in Provider and Sync Management Views
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Dmitri Dolguikh
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 20:29 EDT by Corey Welton
Modified: 2013-08-16 13:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 14:49:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-04-12 20:29:28 EDT
Description of problem:

Sort methods are not the same for these two areas of the UI - they should be uniform

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a new provider, "rpmfusion"
2.  Create a new product, "rpmfusion fedora16"
3.  Create a very large number of repos (at least 12), using the following notation: rpmfusion1, rpmfusion2, rpmfusion3, etc.  You can use the list in "Additional Info" for more
4. After they are all completed, view the ordering of your repos
5. Navigate to Sync Management > Sync Status and expand the list
6. View the ordering of said repos in this view

Actual results:
* In Product view, you get
Repository:  rpmfusion1
Repository:  rpmfusion2
Repository:  rpmfusion3
...
Repository:  rpmfusion10
Repository:  rpmfusion11
Repository:  rpmfusion12

* In Sync view, you get

rpmfusion1
rpmfusion10
rpmfusion11
rpmfusion12
rpmfusion2
rpmfusion3
rpmfusion4

Expected results:
The sorting method should be uniform across the UI

Additional info:
Here are some urls that can be used for repo file creation.

http://download1.rpmfusion.org/free/fedora/releases/16/Everything/x86_64/os/
http://download1.rpmfusion.org/free/fedora/updates/16/x86_64/
http://download1.rpmfusion.org/free/fedora/releases/16/Everything/x86_64/debug/
http://download1.rpmfusion.org/free/fedora/releases/16/Everything/source/SRPMS/
http://download1.rpmfusion.org/free/fedora/updates/16/x86_64/debug/
http://download1.rpmfusion.org/free/fedora/updates/16/SRPMS/
http://download1.rpmfusion.org/nonfree/fedora/releases/16/Everything/x86_64/os/
http://download1.rpmfusion.org/nonfree/fedora/updates/16/x86_64/
http://download1.rpmfusion.org/nonfree/fedora/updates/16/x86_64/debug/
http://download1.rpmfusion.org/nonfree/fedora/updates/16/SRPMS/
http://download1.rpmfusion.org/nonfree/fedora/releases/16/Everything/source/SRPMS/
http://download1.rpmfusion.org/nonfree/fedora/releases/16/Everything/x86_64/debug/
Comment 2 Dmitri Dolguikh 2012-09-25 10:25:04 EDT
Doesn't appear to be the case anymore.
Comment 3 Og Maciel 2012-09-28 16:40:45 EDT
Just to be clear, both views, Product and Sync now show:


rpmfusion1
rpmfusion10
rpmfusion11
rpmfusion12
rpmfusion2
rpmfusion3
rpmfusion4
Comment 4 Og Maciel 2012-09-28 16:41:55 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-9.el6cf.noarch
* katello-all-1.1.12-9.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-5.el6cf.noarch
* katello-cli-common-1.1.8-5.el6cf.noarch
* katello-common-1.1.12-9.el6cf.noarch
* katello-configure-1.1.9-4.el6cf.noarch
* katello-glue-candlepin-1.1.12-9.el6cf.noarch
* katello-glue-pulp-1.1.12-9.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 6 Mike McCune 2013-08-16 13:53:01 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.