Bug 812199 - client log improvements: when running dbench in loop, client log reports "remote operation failed: No data available. Path: (null)"
client log improvements: when running dbench in loop, client log reports "rem...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-13 00:21 EDT by Shwetha Panduranga
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:34:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mount log file (18.32 MB, text/x-log)
2012-04-13 00:21 EDT, Shwetha Panduranga
no flags Details

  None (edit)
Description Shwetha Panduranga 2012-04-13 00:21:04 EDT
Created attachment 577222 [details]
Mount log file

Description of problem:
------------------------

1) The log message reports Path as 'null'. Either it should report gfid of that path or the path name itself.

2) numerous entries of the below mentioned log message is reported in the mount log. should be handled in a better way. 

[2012-04-12 23:58:22.777865] W [client3_1-fops.c:1054:client3_1_getxattr_cbk] 0-dstore-client-0: remote operation failed: No data available. Path: (null)
[2012-04-12 23:58:22.778407] W [client3_1-fops.c:1054:client3_1_getxattr_cbk] 0-dstore-client-2: remote operation failed: No data available. Path: (null)
[2012-04-12 23:58:22.806044] W [client3_1-fops.c:1054:client3_1_getxattr_cbk] 0-dstore-client-1: remote operation failed: No data available. Path: (null)


Version-Release number of selected component (if applicable):
------------------------------------------------------------
3.3.0qa34

How reproducible:
----------------
often

run_dbench.sh:-
---------------
#!/bin/bash

while true;
	do
	dbench -s -F -S --stat-check 10
	dbench -s -F -S -x --one-byte-write-fix --stat-check 10
	done

Steps to Reproduce:
---------------------
1.create a replicate volume (1X3).start the volume
2.create fuse mount. 
3.execute "run_dbench.sh" on fuse mount. 
  
Actual results:
---------------
continuously reports "remote operation failed: No data available. Path: (null)" because application was unable to perform setxattr, getxattr operations. Refer to Bug811957

Additional Info:-
-------------------
[04/13/12 - 15:11:07 root@APP-SERVER1 ~]# gluster volume info
 
Volume Name: dstore
Type: Replicate
Volume ID: bfddf295-51a2-48ab-b048-cd7dcfa3f91e
Status: Started
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Bricks:
Brick1: 192.168.2.35:/export1/dstore1
Brick2: 192.168.2.36:/export1/dstore1
Brick3: 192.168.2.37:/export1/dstore1

------------------
Comment 1 Kaushal 2012-05-08 07:15:49 EDT
Solved by commit 44a1857 "protocol/{client,server} : Log improvements".
With this path both path and gfid will be logged, allowing for identification for cases without path available.
Comment 2 Shwetha Panduranga 2012-05-12 04:03:00 EDT
Bug still exist on 3.3.0qa41. 

mount logs:-
-----------
[2012-05-12 03:58:28.782982] W [client3_1-fops.c:1058:client3_1_getxattr_cbk] 0-vol-client-0: remote operation failed: No data available. Path: (null) (--)
[2012-05-12 03:58:28.784391] W [client3_1-fops.c:1058:client3_1_getxattr_cbk] 0-vol-client-1: remote operation failed: No data available. Path: (null) (--)
[2012-05-12 03:58:28.784937] W [client3_1-fops.c:1058:client3_1_getxattr_cbk] 0-vol-client-2: remote operation failed: No data available. Path: (null) (--)
Comment 3 Anand Avati 2012-05-16 18:53:04 EDT
CHANGE: http://review.gluster.com/3336 (client/protocol : Changes in client3_1_getxattr()) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Kaushal 2012-05-17 00:42:58 EDT
The above change should fix this for good.
Comment 5 Anand Avati 2012-05-17 12:21:21 EDT
CHANGE: http://review.gluster.com/3350 (client/protocol : Changes in client3_1_getxattr()) merged in release-3.3 by Anand Avati (avati@redhat.com)
Comment 6 Shwetha Panduranga 2012-05-21 03:09:28 EDT
Bug is fixed . Verified on 3.3.0qa42

Note You need to log in before you can comment on or make changes to this bug.