Bug 812281 - autofs client: map name length used as key length
Summary: autofs client: map name length used as key length
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-13 09:42 UTC by Jakub Hrozek
Modified: 2020-05-02 16:51 UTC (History)
5 users (show)

Fixed In Version: sssd-1.8.0-23.el6
Doc Type: Bug Fix
Doc Text:
No documentation required
Clone Of:
Environment:
Last Closed: 2012-06-20 11:56:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 2346 None None None 2020-05-02 16:51:55 UTC
Red Hat Product Errata RHBA-2012:0747 normal SHIPPED_LIVE sssd bug fix and enhancement update 2012-06-19 19:31:43 UTC

Description Jakub Hrozek 2012-04-13 09:42:42 UTC
Description of problem:
A copy-and-paste bug in the autofs client caused that the map name is used as key length. This might result in wrong behaviour especially if the key name is longer than map name.

Version-Release number of selected component (if applicable):
1.8.0-22

How reproducible:
haven't tested, the bug is obvious from the code and fixed upstream in 0a78bac242d0172a858d6b65402276aa734a4671 The steps to reproduce below *should* work though.

Steps to Reproduce:
1. create a key with long name, longer than the map name
2. look up the key

  
Actual results:
the key is trimmed to the map length

Expected results:
should work fine

Comment 4 Dmitri Pal 2012-04-16 18:44:22 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1304

Comment 5 Jakub Hrozek 2012-04-18 14:29:36 UTC
I think we need to reconsider this for 6.3. See https://bugzilla.redhat.com/show_bug.cgi?id=683523#c78

Comment 6 Stephen Gallagher 2012-04-18 14:35:15 UTC
Patch is available upstream. Giving devel_ack.

Comment 13 Jenny Severance 2012-04-26 13:53:47 UTC
Autofs is technical preview feature closing bug.

Comment 14 Stephen Gallagher 2012-06-12 12:39:15 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required

Comment 16 errata-xmlrpc 2012-06-20 11:56:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html


Note You need to log in before you can comment on or make changes to this bug.