Bug 812359 - spamd: handled cleanup of child pid [31795] due to SIGCHLD: interrupted
Summary: spamd: handled cleanup of child pid [31795] due to SIGCHLD: interrupted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 16
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-13 13:52 UTC by Jan ONDREJ
Modified: 2012-08-14 01:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-14 01:01:25 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2012-04-13 13:52:54 UTC
Description of problem:
Sometimes spamd was killed for unknown reason.

Version-Release number of selected component (if applicable):
spamassassin-3.3.2-9.fc16.i686

How reproducible:
aprox. once/week, failed 5 times for me aprox. 1-2 months ago

Steps to Reproduce:
Unable to reproduce.
  
Actual results:
Apr 13 14:31:13 ns spamd[1460]: prefork: child states: IBIBBBBI
Apr 13 14:31:13 ns spamd[1460]: spamd: handled cleanup of child pid [31795] due to SIGCHLD: interrupted, signal 2 (0002)

systemctl status spamassassin.service
does not show any running spamd process. Also can't find an process using ps.

Additional info:
This is an PAE kernel with 8 GB RAM. It's planned to upgrade to x86_64, but can't do it now.

Comment 1 Kevin Fenzi 2012-04-13 16:02:39 UTC
I've actually seen this here as well... but thought it was just something weird with my setup or machine since there were no other bug reports. ;) 

If anyone has any ideas on tracking this down, please do chime in.

Comment 2 Kevin Fenzi 2012-04-13 16:04:05 UTC
Could be possibly: 

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6745

Comment 3 Jan ONDREJ 2012-04-14 11:25:16 UTC
There is more in logs today it died:

Apr 13 20:40:21 ns spamd[28009]: prefork: child states: BIIBBI
Apr 13 20:40:21 ns spamd[28009]: prefork: adjust: 3 idle children more than 2 maximum idle children. Decreasing spamd children: 28526 killed.
Apr 13 20:40:21 ns spamd[28009]: spamd: handled cleanup of child pid [28526] due to SIGCHLD: interrupted, signal 2 (0002)
Apr 13 20:40:21 ns spamd[28009]: prefork: child states: BIIBB
Apr 13 20:40:21 ns spamd[28009]: prefork: child states: IIIBB
Apr 13 20:40:21 ns spamd[28009]: prefork: adjust: 3 idle children more than 2 maximum idle children. Decreasing spamd children: 28523 killed.
Apr 13 20:40:21 ns spamd[28009]: spamd: handled cleanup of child pid [28523] due to SIGCHLD: interrupted, signal 2 (0002)

And here is my workaround, which will restart spamd after this problem:

[root@ns ~]# cat /etc/systemd/system/spamassassin.service
.include /lib/systemd/system/spamassassin.service
[Service]
#LimitNOFILE=8192
Restart=always
[root@ns ~]# 

Please, consider adding Restart=always to default init script.

Comment 4 Fedora Update System 2012-08-03 20:55:30 UTC
spamassassin-3.3.2-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/spamassassin-3.3.2-12.fc17

Comment 5 Fedora Update System 2012-08-03 21:06:31 UTC
spamassassin-3.3.2-12.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spamassassin-3.3.2-12.fc16

Comment 6 Fedora Update System 2012-08-05 21:25:37 UTC
Package spamassassin-3.3.2-12.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spamassassin-3.3.2-12.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11496/spamassassin-3.3.2-12.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-08-14 01:01:25 UTC
spamassassin-3.3.2-12.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-08-14 01:02:11 UTC
spamassassin-3.3.2-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.