Bug 812388 - Subscription-manager unsubscribe CLI feedback
Subscription-manager unsubscribe CLI feedback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-04-13 11:00 EDT by Matt Reid
Modified: 2013-01-07 22:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:50:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-04-13 11:00:43 EDT
Description of problem:
When a user types in subscription-manager unsubscribe --all, they don't see anything happen, they just get a new prompt line.

Version-Release number of selected component (if applicable):
subscription-manager-1.0.0-1.git.19.46c8d80

Actual results:
[user@system]# subscription-manager unsubscribe --all
[user@system]#

Expected results:
[user@system]# subscription-manager unsubscribe --all
Successfully unsubscribed from [however many] subscriptions.
[user@system]#

We should at the very least give a summary of how many subscriptions they just unsubscribed from by running that command. Might be even more useful to show the name of the subscription they just freed up, but that could be more than they care about. I think adding in the above general line is a good starting point.

Additional Information:
Does anyone have an opinion on if a system is only consuming 1 subscription, if they should be able to run subscription-manager unsubscribe without specifying a serial or --all and have it remove their only subscription? Seems a little silly to make them specify which when there's just one option, but I'm not sure how hard that would be implementation-wise.
Comment 1 RHEL Product and Program Management 2012-04-16 22:08:36 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Alex Wood 2012-05-04 10:32:40 EDT
This bug is a little tricky because it required both a Candlepin and subscription-manager change.

Committed to Candlepin (candlepin-0.6.2+) :
commit 220df7457fff58adc18a96fa2da33cd9d981ff8b
Author: Alex Wood <awood@redhat.com>
Date:   Thu May 3 14:20:54 2012 -0400

    812388: Return the number of entitlements removed or revoked.
    
    removeAllEntitlements and revokeAllEntitlements now return the
    number of entitlements they modified.

Committed to subscription-manager (subscription-manager-1.0.2+):
commit a9fd5370dc1b5697668eb0a30145cabef5157862
Author: Alex Wood <awood@redhat.com>
Date:   Thu May 3 14:29:19 2012 -0400

    812388: Show the number of entitlements unsubscribed from.
Comment 3 Shwetha Kallesh 2012-06-20 11:00:29 EDT
Verified!!

RPM used:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.4-1.git.0.5943ee7.el5
subscription-manager-1.0.4-1.git.0.5943ee7.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.0.5943ee7.el5
subscription-manager-migration-1.0.4-1.git.0.5943ee7.el5


[root@dhcp201-196 ~]# subscription-manager unsubscribe --all
This machine has been unsubscribed from 1 subscriptions
Comment 6 errata-xmlrpc 2013-01-07 22:50:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.