Bug 812389 - mod_proxy not enabled
mod_proxy not enabled
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 11:04 EDT by Alexander Todorov
Modified: 2015-05-14 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 14:49:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2012-04-13 11:04:04 EDT
Description of problem:

Looks like mod_proxy is either not enabled or not present at all for httpd on OpenShift (python cartridge at least). 


The error message is:
[Fri Apr 13 10:48:12 2012] [error] [client 127.9.225.129] File does not exist: proxy:http://127.9.225.129:8080/static/README


A quick google for "File does not exist: proxy:http" shows this message appears when httpd is not compiled with mod_proxy.  Please fix it. 


The long story behind this request is here:
https://www.redhat.com/openshift/community/forums/openshift/modrewritemodproxy-issues-with-python-cartirdge

This is preventing me from using OpenShift as origin server to Amazon CloudFront for serving static files. I'm doing it this way because: 

1) My static content is kept under the application source in git and easily managed - CSS, JavaScript, small images, etc. Also no need to push to external server only to get the content mirrored to CDN.

2) I can easily commit and push content to OpenShift when I have to change something. 

3) I can easily tell my HTML template to access CloudFront using a version in the URL so it will load the latest version of the files (from CDN, not from OpenShift). 

4) This way I don't have to keep multiple directories around. 


If only this RewriteRule worked.
Comment 1 Mike McGrath 2012-04-13 11:57:36 EDT
mod proxy is a memory eater.  we'll have to see if this is something we want to fix or use the DIY cart for.
Comment 2 Mike McGrath 2012-10-10 14:49:39 EDT
We recommend a DIY for this use case, mod_proxy shouldn't be enabled for everyone because it does make the memory footprint of httpd larger for people not using it.

Note You need to log in before you can comment on or make changes to this bug.