Bug 81241 - cipe interface preventing route from going into kernel
cipe interface preventing route from going into kernel
Status: CLOSED DUPLICATE of bug 81239
Product: Red Hat Linux
Classification: Retired
Component: cipe (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-06 18:45 EST by Ted Kaczmarek
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2003-01-06 18:45:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030104

Description of problem:
Route will not install if cipe interface ip is in same address space.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Bring up cipe inteface on HOST A with ip of 192.168.200.1 and HOST B peer of
192.168.200.2
2.Have bgp peer HOST A send 192.168.0.0/16 route to HOST B
3.Confirm route in bgp table, not in kernel routing table
    

Actual Results:  Route of 192.168.0.0/16 is not put in kernel routing table.

Expected Results:  Route of 192.168.0.0/16 is put into kernel routing table.

Additional info:

As a test instead of sending the /16 which overlaps the cipe interface, I sent
it as a /17, that route does get put into the kernel routing table. Wasn't sure
if this is kernel or cipe, but it is definelty cipe related. I even advertised
the same route from another peer (Router C)across the ethernet0 and saw the same
issue.

Will attach a diagram as well.
Comment 1 Ted Kaczmarek 2003-01-06 18:50:36 EST

*** This bug has been marked as a duplicate of 81239 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:50:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.