Bug 812410 - Subscription-manager subscribe CLI feedback
Subscription-manager subscribe CLI feedback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-04-13 12:03 EDT by Matt Reid
Modified: 2013-01-07 22:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:50:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-04-13 12:03:44 EDT
Description of problem:
Subscribing manually through the CLI simply repeats the pool id they input as confirmation. It would be nicer if we translated that pool id back to a subscription name for them or also displayed it in some fashion. My assumption is that subscription names are more easily recognizable than pool ids.

Version-Release number of selected component (if applicable):
subscription-manager-1.0.0-1.git.19.46c8d80

Steps to Reproduce:
1. subscription-mananger list --available
2. copy pool id
3. subscription-manager subscribe --pool=[paste pool id]
  
Actual results:
[user@sys]# subscription-manager subscribe --pool=[poolid]
Successfully consumed a subscription from the pool with id [pool id].
[user@sys]#

Expected results:
[user@sys]# subscription-manager subscribe --pool=[poolid]
Successfully consumed a subscription for [subscription name] from pool id: [pool id].
[user@sys]#

or 

[user@sys]# subscription-manager subscribe --pool=[poolid]
Successfully consumed a subscription for [subscription name].
[user@sys]#

Additional info:
I imagine there's not much we can do about pools, but it seems pretty painful to manually subscribe. What if they don't have a mouse and they're just ssh'd in? Is there a wizardy way they can copy/paste the pool id and not have to write it down somewhere else and then input it manually?
Comment 1 RHEL Product and Program Management 2012-04-16 22:08:32 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Devan Goodwin 2012-05-25 14:42:21 EDT
Changed to:

subscription-manager subscribe --pool=ff8080813783f91c013783fa178105c6 --pool=ff8080813783f91c013783fa16280597
Successfully consumed a subscription for: Awesome OS Modifier
Successfully consumed a subscription for: Awesome OS Server Bundled
Comment 3 Devan Goodwin 2012-05-29 09:12:11 EDT
fixed in subscription-manager upstream: 98819d99b548e3f4ff142c1748b9dbdcaa7ef40c

Will appear in subscription-manager-1.0.3-1 and later.
Comment 4 spandey 2012-06-18 08:23:34 EDT
Verified using following rpm 

subscription-manager-firstboot-1.0.3-1.git.75.a0245f2.el5
subscription-manager-1.0.3-1.git.75.a0245f2.el5
subscription-manager-gui-1.0.3-1.git.75.a0245f2.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-migration-1.0.3-1.git.75.a0245f2.el5



[root@dhcp193-122 product]# subscription-manager subscribe --pool 0000000037fe871b0137fe8893520480 --pool 0000000037fe871b0137fe888f6e03d7
Successfully consumed a subscription for: Awesome OS with unlimited virtual guests
Successfully consumed a subscription for: Stackable with Awesome OS for x86_64

resolving defect as verified
Comment 6 errata-xmlrpc 2013-01-07 22:50:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.