Bug 812444 - Alsamixer cannot be run as "su" with a RHEL 6.3 guest on a 5.8 host
Summary: Alsamixer cannot be run as "su" with a RHEL 6.3 guest on a 5.8 host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Wim Taymans
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-13 18:22 UTC by Bill Sanford
Modified: 2015-03-09 08:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-09 08:24:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0655 normal SHIPPED_LIVE pulseaudio bug fix update 2015-03-09 12:24:25 UTC

Description Bill Sanford 2012-04-13 18:22:06 UTC
Description of problem: 
On RHEV-M ic155, I have 5.8 hosts and a RHEL 6.3 guest on the host. I try to run alsamixer as "su" and get the following error. If I change user to the user that logged into RHEL 6.3, I can use alsamixer with no error.

This does not happen on a RHEL 5.8 guest.

[root@dhcp66 ~]# alsamixer
ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused
[root@dhcp66 ~]# su test
[test@dhcp66 root]$ alsamixer
[test@dhcp66 root]$ exit
exit
[root@dhcp66 ~]# exit

Version-Release number of selected component (if applicable):
RHEL 6.3

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL 6.3 as a guest on a 5.8 host within RHEV-M ic155.
2. Change to su and type alsamixer.
3.
  
Actual results:
The alsamixer utility connection was refused.

Expected results:
The alsamixer utility should appear.

Additional info:

Comment 1 Marc-Andre Lureau 2012-04-13 18:33:15 UTC
this is not a spice bug,

please reassign

Comment 2 Jaroslav Kysela 2012-04-23 13:22:34 UTC
Does 'alsamixer -c 0' work?

You may also remove the pulseaudio packages from the virtual machine. It should have same effect.

Comment 3 Bill Sanford 2012-05-04 14:35:16 UTC
I just installed RHEV-M sm111 (2.2) and added two 5.8 hosts and if you are 'su' alsamixer still fails.

I just confirmed that 'alsamixer -c 0' does work in RHEV-M sm111.

Comment 4 Jaroslav Kysela 2014-01-29 09:13:20 UTC
I think that it belongs to the pulseaudio configuration in RHEL 6.3..

Comment 6 Wim Taymans 2014-06-23 15:03:53 UTC
Is this running without a GUI? If so, users must manually copy the pulseaudio cookie file around to be able to connect to pulseaudio.

as root, do:

 mkdir /root/.pulse
 cp /home/user/test/.pulse/cookie /root/.pulse/cookie

then try:

 alsamixer

again.

Comment 7 Bill Sanford 2014-09-08 13:10:53 UTC
I have looked and cant find this in the documentation, anywhere. Is this documented?

Comment 8 Wim Taymans 2014-09-08 14:31:25 UTC
It is not sufficiently documented, IMO. 

It depends a bit on the modules you load, but the default one uses a cookie to authorize clients. There is a hint about the cookie in the manpage but I'll see if it can be more more explicit.

Comment 12 errata-xmlrpc 2015-03-09 08:24:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0655.html


Note You need to log in before you can comment on or make changes to this bug.