Bug 812501 - ypbind not registered with rpcbind
ypbind not registered with rpcbind
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 23:53 EDT by David Highley
Modified: 2012-04-27 01:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: ypbind-1.35-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log from booting system that has ypbind-rpcbind problem (206.12 KB, text/plain)
2012-04-16 19:07 EDT, Michael Glass
no flags Details
/var/log/messages file that corresponds to dmesg file (94.98 KB, text/plain)
2012-04-16 19:09 EDT, Michael Glass
no flags Details
use proper DBus message string (1.25 KB, patch)
2012-04-18 09:23 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description David Highley 2012-04-13 23:53:29 EDT
Description of problem:
ypbind is seems to start before rpcbind

Version-Release number of selected component (if applicable):
ypbind-1.35-1.fc16.x86_64

How reproducible:
Three out of four systems restarted with this issue.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
systemctl restart ypbind.service; corrects the issue but deadly if offsite and remote root access not allowed.
Comment 1 Honza Horak 2012-04-16 05:56:47 EDT
Could you attach output of dmesg to see ordering of services and systemd events during boot? To do so, boot with "log_buf_len=1M systemd.log_level=debug systemd.log_target=kmsg".
Comment 2 Michael Glass 2012-04-16 19:07:47 EDT
Created attachment 577853 [details]
dmesg log from booting system that has ypbind-rpcbind problem

We were having the same bug:
--ypbind not registered with rpcbind at boot (although ypbind seems to be running)
--systemctl restart ypbind.service makes it work
--yum downgrade fixes the problem.

I followed the instructions to log systemd messages. This is the dmesg file that comes out.

The next file will be the /var/log/messages from the same boot.
Comment 3 Michael Glass 2012-04-16 19:09:40 EDT
Created attachment 577854 [details]
/var/log/messages file that corresponds to dmesg file

This is the /var/log/messages file that corresponds to the dmesg file just attached.  It starts with the current boot.  (The weird times--2000 seconds for rpcbind work---comes from the BIOS time being wrong, and fixed by ntpd.)
Comment 4 Honza Horak 2012-04-18 09:23:19 EDT
Created attachment 578349 [details]
use proper DBus message string

The problem is probably in communication with NetworkManager. A wrong constant is used for listening on DBus, so ypbind don't notice network is ready and waits for a connection forever.
Comment 5 Fedora Update System 2012-04-18 09:28:11 EDT
ypbind-1.35-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ypbind-1.35-2.fc16
Comment 6 Fedora Update System 2012-04-18 09:29:18 EDT
ypbind-1.35-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ypbind-1.35-2.fc17
Comment 7 Fedora Update System 2012-04-18 18:13:34 EDT
Package ypbind-1.35-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ypbind-1.35-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6135/ypbind-1.35-2.fc17
then log in and leave karma (feedback).
Comment 8 Dr. Tilmann Bubeck 2012-04-21 13:44:38 EDT
I had the same issue and ypbind-1.35-2 fixed it for f16.
Thanks!
Comment 9 David Highley 2012-04-21 22:23:03 EDT
Seems to be fixed now, thanks.
Comment 10 Michael Glass 2012-04-25 19:06:17 EDT
Seems fixed our our FC16 systems also.
Comment 11 Fedora Update System 2012-04-26 16:06:13 EDT
ypbind-1.35-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-04-27 01:50:43 EDT
ypbind-1.35-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.