Bug 812549 - Impossible to deactivate logical volume (group) on external usb disk
Impossible to deactivate logical volume (group) on external usb disk
Status: CLOSED DUPLICATE of bug 808795
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-14 14:08 EDT by Wilfried Philips
Modified: 2013-02-09 08:36 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-15 13:47:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wilfried Philips 2012-04-14 14:08:14 EDT
Description of problem:

I use an external USB hard disk for backups. It has two volume groups
called BigBackupVg and BigbackupVg2

After unmounting the filesysystems on the external disk it is not possible
to deactivate the volume groups. This used to work under F14 and earlier

Version-Release number of selected component (if applicable):

F16. Installed latest updates today

uname -a 
Linux  3.3.1-5.fc16.x86_64 #1 SMP Tue Apr 10 19:56:52 UTC 2012 x86_64 x86_64 x86_64 GNU/Linu

How reproducible:
Always

Steps to Reproduce:
1. activate the volume group and mount the device

sudo vgscan && sudo vgchange -a y BigBackupVg &&
sudo mount /dev/mapper/BigBackupVg-lvol0 /mnt/backup/

2. unmount the device 

sudo umount /mnt/backup/ 


mount |grep backup

shows nothing. The unmount has worked.


3. sudo vgchange -a n BigBackupVg 

  
Actual results:

 Can't deactivate volume group "BigBackupVg" with 1 open logical volume(s)

Expected results:

Volume group should be deactivated.

Additional info:



If I don't moutn a filesystem, the volume CAN be deactivated.

ls -al /dev/BigBackupVg/lvol0 
lrwxrwxrwx. 1 root root 7 Apr 14 19:30 /dev/BigBackupVg/lvol0 -> ../dm-7

ps auxwwww|grep 'dm-7'
root      2362  0.0  0.0      0     0 ?        S    19:30   0:00 [jbd2/dm-7-8]


This thread should no longer exist after unmounting, should it?


When mounted:

/dev/mapper/BigBackupVg-lvol0 on /mnt/backup type ext3 (rw,relatime,seclabel,user_xattr,acl,barrier=1,nodelalloc,data=ordered)
Comment 1 Milan Broz 2012-04-15 13:47:49 EDT
Please disable sandbox service and reboot...

*** This bug has been marked as a duplicate of bug 808795 ***
Comment 2 Elías Halldór Ágústsson 2013-02-09 08:36:52 EST
Try swapoff -a

Note You need to log in before you can comment on or make changes to this bug.