Bug 812556 - Value of specifier not listed status output for failed service
Value of specifier not listed status output for failed service
Status: CLOSED DUPLICATE of bug 772073
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-14 15:59 EDT by Jóhann B. Guðmundsson
Modified: 2012-10-30 17:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 17:43:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2012-04-14 15:59:22 EDT
Description of problem:

The summary says it all

Version-Release number of selected component (if applicable):

systemd-37-17.fc16.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Create a template unit
2. Ensure the relevant service tied to the template fails at startup 
3. start the service tied to the template 
4. check status of service
  
Actual results:

The value of the specifier not shown for the failing unit as in the 
"Process" field for the failed or stopped unit shows %foo instead of the value that was actually used. 


Expected results:

The value of the specifier to be shown as when unit is running normally

Sample output

The status of service running ( correct )

├ 6931 /bin/sh /usr/share/jboss-as/bin/standalone.sh -c standalone-1.xml <-- =)

The status of the stopped or failed unit ( Wrong ) 

Process: 6931 ExecStart=/usr/share/jboss-as/bin/standalone.sh -c %i.xml <-- =(

Additional info:

When throwing the holy hand grenade of Antioch first shalt thou take out the Holy Pin, then shalt thou count to three, no more, no less. Three shall be the number thou shalt count, and the number of the counting shall be three. Four shalt thou not count, neither count thou two, excepting that thou then proceed to three. Five is right out. Once the number three, being the third number, be reached, then lobbest thou thy Holy Hand Grenade of Antioch towards thy foe, who being naughty in My sight, shall snuff it...
Comment 1 Michal Schmidt 2012-04-16 06:46:24 EDT
Seems related to bug 772073.
Comment 2 Lennart Poettering 2012-10-30 17:43:12 EDT

*** This bug has been marked as a duplicate of bug 772073 ***

Note You need to log in before you can comment on or make changes to this bug.