Bug 812560 - [abrt] openttd-1.2.0-0.1.RC4.fc17: __GI_raise: Process /usr/bin/openttd was killed by signal 6 (SIGABRT)
Summary: [abrt] openttd-1.2.0-0.1.RC4.fc17: __GI_raise: Process /usr/bin/openttd was k...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openttd
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Kaechele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6f7d375daa3502e1432aefa9efc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-14 21:23 UTC by Simon Farnsworth
Modified: 2012-04-15 15:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-15 15:47:41 UTC


Attachments (Terms of Use)
File: backtrace (11.67 KB, text/plain)
2012-04-14 21:23 UTC, Simon Farnsworth
no flags Details
File: maps (8.63 KB, text/plain)
2012-04-14 21:23 UTC, Simon Farnsworth
no flags Details
crash.log from the crashed openttd (1.67 KB, text/plain)
2012-04-15 10:47 UTC, Simon Farnsworth
no flags Details
openttd.cfg that is suspected of crashing OpenTTD (9.63 KB, application/octet-stream)
2012-04-15 13:16 UTC, Simon Farnsworth
no flags Details

Description Simon Farnsworth 2012-04-14 21:23:12 UTC
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/openttd
comment:        I attempted to run openttd from the KDE menu
crash_function: __GI_raise
executable:     /usr/bin/openttd
kernel:         3.3.1-3.fc16.x86_64
pid:            12121
pwd:            /home/simon/Documents
remote_result:  NOTFOUND
time:           Sat 14 Apr 2012 10:15:28 PM BST
uid:            1100
username:       simon

backtrace:      Text file, 11950 bytes
maps:           Text file, 8836 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/simon/6

core_backtrace:
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0x35915 raise libc.so.6 -
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0x370c8 abort libc.so.6 -
:44fcab1e65207ed363615f034c996451ebca5bf5 0x34b7f0 _start [exe] -

dso_list:
:/usr/lib64/libicui18n.so.48.1.1 libicu-4.8.1.1-2.fc17.x86_64 (Fedora Project) 1334362152
:/usr/lib64/libfontconfig.so.1.4.4 fontconfig-2.8.0-6.fc17.x86_64 (Fedora Project) 1334362037
:/usr/lib64/libicudata.so.48.1.1 libicu-4.8.1.1-2.fc17.x86_64 (Fedora Project) 1334362152
:/usr/lib64/libSDL-1.2.so.0.11.3 SDL-1.2.14-16.fc17.x86_64 (Fedora Project) 1334362052
:/usr/lib64/liblzma.so.5.0.99 xz-libs-5.1.1-2alpha.fc17.x86_64 (Fedora Project) 1334362087
:/usr/lib64/liblzo2.so.2.0.0 lzo-2.06-2.fc17.x86_64 (Fedora Project) 1334362422
:/usr/lib64/libm-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007
:/usr/lib64/libc-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007
:/usr/lib64/libtimidity-0.1.so.0.0.0 libtimidity-0.1.0-10.fc17.x86_64 (Fedora Project) 1334365191
:/usr/lib64/ld-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007
:/usr/lib64/libfreetype.so.6.8.0 freetype-2.4.8-3.fc17.x86_64 (Fedora Project) 1334362023
:/usr/lib64/libstdc++.so.6.0.17 libstdc++-4.7.0-1.fc17.x86_64 (Fedora Project) 1334362018
:/usr/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc17.x86_64 (Fedora Project) 1334362018
:/usr/lib64/librt-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007
:/usr/lib64/libgcc_s-4.7.0-20120322.so.1 libgcc-4.7.0-1.fc17.x86_64 (Fedora Project) 1334361947
:/usr/bin/openttd openttd-1.2.0-0.1.RC4.fc17.x86_64 (Fedora Project) 1334399025
:/usr/lib64/libpng15.so.15.10.0 libpng-2:1.5.10-1.fc17.x86_64 (Fedora Project) 1334362026
:/usr/lib64/libdl-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007
:/usr/lib64/libicuuc.so.48.1.1 libicu-4.8.1.1-2.fc17.x86_64 (Fedora Project) 1334362152
:/usr/lib64/libexpat.so.1.6.0 expat-2.1.0-1.fc17.x86_64 (Fedora Project) 1334362036
:/usr/lib64/libpthread-2.15.so glibc-2.15-32.fc17.x86_64 (Fedora Project) 1334362007

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=6
:SSH_AGENT_PID=6391
:HOSTNAME=lister.farnz.org.uk
:DM_CONTROL=/var/run/xdmctl
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:HISTSIZE=1000
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/simon/.gtkrc-2.0:/home/simon/.gtkrc-2.0-kde4:/home/simon/.kde/share/config/gtkrc-2.0
:GS_LIB=
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:USER=simon
:SSH_AUTH_SOCK=/tmp/ssh-VfPxoMIg5911/agent.5911
:MAIL=/var/spool/mail/simon
:DESKTOP_SESSION=default
:PATH=/usr/lib64/qt-3.3/bin:/home/simon/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/simon/.cabal/bin:/home/simon/AndroidSDK:/home/simon/AndroidSDK/tools
:PWD=/home/simon
:KDE_SESSION_UID=1100
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:KRB5CCNAME=FILE:/tmp/krb5cc_1100_DvPFhj
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/simon
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=Adwaita
:LOGNAME=simon
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-KBiszU0n2Y,guid=db2fd85d99461219714f65be00008828
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/simon
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/simon/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:XAUTHORITY=/tmp/kde-simon/xauth-1100-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/13163,unix/unix:/tmp/.ICE-unix/13163
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/simon/.gtkrc:/home/simon/.kde/share/config/gtkrc
:DESKTOP_STARTUP_ID=lister.farnz.org.uk;1334438127;726727;13235_TIME70980324

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31403                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31403                31403                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[43720]
:pos:	0
:flags:	00
:1:/home/simon/.xsession-errors
:pos:	297933
:flags:	0100001
:2:/home/simon/.xsession-errors
:pos:	297933
:flags:	0100001

smolt_data:
:
:
:General
:=================================
:UUID: f9b685c8-18a5-4f90-816f-d7465d1c29da
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3657.25
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T5550  @ 1.83GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1833
:System Memory: 3946
:System Swap: 5997
:Vendor: Dell Inc.
:System: Inspiron 1525 
:Form factor: Portable
:Kernel: 3.3.1-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:2082:4136:559) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:2098:4136:559) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2130:4136:559) pci, r852, BASE, xD-Picture Card Controller
:(4480:1426:4136:559) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(32902:10752:4136:559) pci, agpgart-intel, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:16930:32902:4129) pci, iwl3945, NETWORK, PRO/Wireless 3945ABG [Golan] Network Connection
:(32902:10302:4136:559) pci, i801_smbus, SERIAL, 82801H (ICH8 Family) SMBus Controller
:(32902:10281:4136:559) pci, ahci, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller
:(32902:10320:4136:559) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10261:4136:559) pci, None, PCI/ISA, 82801HEM (ICH8M) LPC Interface Controller
:(4523:17236:4136:559) pci, sky2, ETHERNET, 88E8040 PCI-E Fast Ethernet Controller
:(32902:9288:4136:559) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10289:4136:559) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:10288:4136:559) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10290:4136:559) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(32902:10294:4136:559) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(32902:10298:4136:559) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(32902:10754:4136:559) pci, i915, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (primary)
:(32902:10755:4136:559) pci, None, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (secondary)
:(32902:10303:4136:559) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4136:559) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10311:4136:559) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 5
:(32902:10315:4136:559) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:10292:4136:559) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(32902:10293:4136:559) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-93aa8bd3-4edd-424c-b8ab-d7e5b63aaac3 / btrfs 4096 4096 59384832 28394504 26753664 0 0 0
:/dev/sda1 /boot ext4 1024 1024 508745 412153 386553 128016 127785 127785
:

var_log_messages:
:Apr 14 11:23:43 lister yum[1474]: Updated: openttd-opengfx-0.4.3-1.fc17.noarch
:Apr 14 11:23:46 lister yum[1474]: Updated: openttd-1.2.0-0.1.RC4.fc17.x86_64
:Apr 14 11:33:07 lister yum[1474]: Updated: openttd-docs-1.2.0-0.1.RC4.fc17.noarch
:Apr 14 22:15:29 lister abrt[12122]: Saved core dump of pid 12121 (/usr/bin/openttd) to /var/spool/abrt/ccpp-2012-04-14-22:15:28-12121 (2457600 bytes)

Comment 1 Simon Farnsworth 2012-04-14 21:23:18 UTC
Created attachment 577482 [details]
File: backtrace

Comment 2 Simon Farnsworth 2012-04-14 21:23:20 UTC
Created attachment 577483 [details]
File: maps

Comment 3 Felix Kaechele 2012-04-15 10:11:10 UTC
Did you have OpenTTD 0.5 or older installed at some point, or was you config directory created by a OpenTTD version older than 0.5?

Could you just try to rename your ~/.openttd folder and have OpenTTD create a new one?

Also upstream would be very interested in having the crash.log and crash.dmp that OpenTTD should have created in the ~/.openttd folder when it crashed.

If you need any assistance with this I'm here to help :)

Comment 4 Simon Farnsworth 2012-04-15 10:46:14 UTC
I've played various versions of OpenTTD - 0.5 is plausible. Renaming .openttd to .openttd.crash caused it to crash.

I can't find crash.dmp in .openttd:

simon@lister:~$ find ~/.openttd.crash/ -name 'crash.*'
/home/simon/.openttd.crash/crash.log
simon@lister:~$

I will upload crash.log shortly.

Comment 5 Simon Farnsworth 2012-04-15 10:47:15 UTC
Created attachment 577506 [details]
crash.log from the crashed openttd

crash.log, as requested. Can't find crash.dmp - otherwise I'd upload that too.

Comment 6 Simon Farnsworth 2012-04-15 10:50:07 UTC
Accidentally used my work Bugzilla account to add the crashdump, not my personal one - fixing up the CC list.

Comment 7 Felix Kaechele 2012-04-15 11:22:16 UTC
Okay, so what we think happens here is that an error is found while loading the config file.
The error you are seeing is given when loading of the config fails in a very early stage (i.e. before a language file is loaded).
This is most likely due to an error in the [misc] section of the config file.

Did I understand you correctly that this even occurs when you have OpenTTD completely regenerate the config file?

Is there a chance that some files of an old OpenTTD may be still lingering around your filesystem?

Comment 8 Felix Kaechele 2012-04-15 11:25:24 UTC
Upstream bug report is here: http://bugs.openttd.org/task/5154

Comment 9 Simon Farnsworth 2012-04-15 12:51:12 UTC
I have been unclear - renaming .openttd to .openttd.crash permitted OpenTTD to start properly, at the expense of losing all my settings (obviously).

Would a copy of openttd.cfg from the failing .openttd directory be of interest to either you or upstream? If so, I can upload it here.

Comment 10 Felix Kaechele 2012-04-15 12:56:08 UTC
Yes a copy of the failing openttd.cfg would be great.

Comment 11 Simon Farnsworth 2012-04-15 13:16:15 UTC
Created attachment 577537 [details]
openttd.cfg that is suspected of crashing OpenTTD

Here's the openttd.cfg - I've got the entire configuration directory to one side (not interfering with my entertainment), so I can give you other files from it as desired.

Comment 12 Felix Kaechele 2012-04-15 14:06:29 UTC
Okay so thanks for pointing this bug out. Upstream will try to have OpenTTD show a helpful error message if the misc section of the config is broken.

To fix your specific bug you can do this in your .openttd directory (the one that was failing):
sed -i 's/TRANS_BUILDINGS|FULL_DETAIL|WAYPOINTS/FULL_DETAIL|WAYPOINTS|SHOW_COMPETITOR_SIGNS/' openttd.cfg

This should fix the startup error but leave all your settings intact.

Comment 13 Simon Farnsworth 2012-04-15 15:18:45 UTC
(In reply to comment #12)
> Okay so thanks for pointing this bug out. Upstream will try to have OpenTTD
> show a helpful error message if the misc section of the config is broken.
> 
Thank you for taking the time to handle this bug report and take it to upstream.

> To fix your specific bug you can do this in your .openttd directory (the one
> that was failing):
> sed -i
> 's/TRANS_BUILDINGS|FULL_DETAIL|WAYPOINTS/FULL_DETAIL|WAYPOINTS|SHOW_COMPETITOR_SIGNS/'
> openttd.cfg
> 
> This should fix the startup error but leave all your settings intact.

I can confirm that this fixes the start error, and leaves my settings in place.

Comment 14 Felix Kaechele 2012-04-15 15:48:35 UTC
Sure, no problem.
Thank you for taking the time to filing this bug :)


Note You need to log in before you can comment on or make changes to this bug.