Bug 8126 - elm 2.4x severe y2k problem
elm 2.4x severe y2k problem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
5.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-02 22:59 EST by flaps
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-02 22:59:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description flaps 2000-01-02 22:59:43 EST
In the version of elm distributed with redhat 5.2, the current year (2000)
is stated as "100" when you send a message.  This problem seems not to
exist in the redhat 6.0 elm.  The source code fix is undoubtedly trivial
(change a "tm_year" to "tm_year+1900" somewhere, to use four-digit years).
Alternatively just compile elm 2.5x for glibc 2.0 or whatever it takes to
make it able to run on a redhat 5.2 system.  The elm "errata" rpm for 5.0
(and 5.1?) seems to be the same as the redhat 5.2 distributed rpm, namely
elm-2.4.25-14; so this also applies to redhat 5.0 and can hopefully use the
same bugfix rpm.  Presumably redhat 4.2 has the same problem too, if you're
still supporting that.

Let me know if you'd like me to track down the appropriate "tm_year" in the
source code, if you want to go that route rather than the 2.5x route.  (I
assume this will be trivial upon investigation but I'm happy to do it if it
turns out not to be.)

thanks,
Comment 1 Trond Eivind Glomsrxd 2001-01-19 18:35:42 EST
Somehow, a package (2.5.1) was built for 5.2 but I can't see that we released
it. I'm sorry about that. Rebuilding the SRPM for one in 6.x series should work
just fine, though - and if you mail me, I can send you the RPM. To repeat - I'm
sorry about that.

Note You need to log in before you can comment on or make changes to this bug.