Bug 812601 - [abrt] gnome-shell-3.2.2.1-1.fc16: cogl_object_unref: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
[abrt] gnome-shell-3.2.2.1-1.fc16: cogl_object_unref: Process /usr/bin/gnome-...
Status: CLOSED DUPLICATE of bug 702257
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:40d693f0eca311ef8a8607d0841...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 07:05 EDT by Tim Zorn
Modified: 2012-04-30 10:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 10:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (20.42 KB, text/plain)
2012-04-15 07:05 EDT, Tim Zorn
no flags Details
File: build_ids (6.41 KB, text/plain)
2012-04-15 07:05 EDT, Tim Zorn
no flags Details
File: maps (79.49 KB, text/plain)
2012-04-15 07:05 EDT, Tim Zorn
no flags Details
File: xsession_errors (15.38 KB, text/plain)
2012-04-15 07:05 EDT, Tim Zorn
no flags Details
File: backtrace (32.28 KB, text/plain)
2012-04-15 07:05 EDT, Tim Zorn
no flags Details

  None (edit)
Description Tim Zorn 2012-04-15 07:05:43 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
comment:        Still having this problem consistently. This one happened as I switched to Seamless Mode in Virtual Box 2D and 3D acceloration are enabled in Virtual Box
crash_function: cogl_object_unref
executable:     /usr/bin/gnome-shell
kernel:         3.3.0-8.fc16.x86_64
pid:            8519
pwd:            /home/tim
reason:         Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
time:           Sun 15 Apr 2012 07:02:18 AM EDT
uid:            1000
username:       tim

backtrace:      Text file, 33052 bytes
build_ids:      Text file, 6562 bytes
dso_list:       Text file, 20910 bytes
maps:           Text file, 81393 bytes
xsession_errors: Text file, 15751 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Tim
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=b18fa2979c04e18f799af6d00000000c-1334456737.568710-1045773860
:GNOME_KEYRING_CONTROL=/tmp/keyring-SdpLhG
:IMSETTINGS_MODULE=none
:USER=tim
:LIBGL_DRIVERS_PATH=/usr/lib/dri:/usr/lib64/dri
:G_SLICE=always-malloc
:USERNAME=tim
:MAIL=/var/spool/mail/tim
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/tim/.local/bin:/home/tim/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/tim
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1485
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/tim
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=tim
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-6hr89WkuIP,guid=fb0fa72dd89b84a943ff5bcc00000023
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/tim
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-tim-Cqdafe/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1490,unix/unix:/tmp/.ICE-unix/1490
:GPG_AGENT_INFO=/tmp/keyring-SdpLhG/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-SdpLhG/ssh
:DESKTOP_AUTOSTART_ID=10b8052fe0448047fc133445673818202000000014900000

event_log:
:2012-04-15-07:03:40> Analyzing coredump 'coredump'
:2012-04-15-07:03:43  Coredump references 161 debuginfo files, 3 of them are not installed
:2012-04-15-07:03:43  Setting up yum repositories
:2012-04-15-07:03:52  Looking for needed packages in repositories
:2012-04-15-07:04:03  Can't find packages for 1 debuginfo files
:2012-04-15-07:04:03  Packages to download: 1
:2012-04-15-07:04:34  Downloading 3.47Mb, installed size: 17.81Mb. Continue? YES
:2012-04-15-07:04:36  Downloading (1 of 1) openssl-debuginfo-1.0.0h-1.fc16.x86_64.rpm: 100
:2012-04-15-07:04:36  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-04-15-07:03:40.9213/openssl-debuginfo-1.0.0h-1.fc16.x86_64.rpm
:2012-04-15-07:04:37  Caching files from unpacked.cpio made from openssl-debuginfo-1.0.0h-1.fc16.x86_64.rpm
:2012-04-15-07:04:37  Removing /tmp/abrt-tmp-debuginfo-2012-04-15-07:03:40.9213
:2012-04-15-07:04:37  Missing debuginfo file: /usr/lib/debug/.build-id/-/.debug
:2012-04-15-07:04:37  Generating backtrace
:2012-04-15-07:04:45  Backtrace is generated and saved, 33052 bytes
:2012-04-15-07:05:11> Element 'xsession_errors' saved
:2012-04-15-07:05:11> GConf directory /apps/gnome-shell does not exist
:2012-04-15-07:05:11* (exited with 1)
:2012-04-15-07:05:12> Smolt profile successfully saved

smolt_data:
:
:
:General
:=================================
:UUID: 09e4a591-1c12-466c-9c5e-832436771f7d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5986.99
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) II X2 250 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 3951
:System Swap: 1998
:Vendor: To Be Filled By O.E.M.
:System: To Be Filled By O.E.M. To Be Filled By O.E.M.
:Form factor: Desktop
:Kernel: 3.3.0-8.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17296:6217:17296) pci, ahci, STORAGE, Motherboard (one of many)
:(4098:43656:5963:43656) pci, snd_hda_intel, MULTIMEDIA, Barts HDMI Audio [Radeon HD 6800 Series]
:(4098:23060:6217:23060) pci, None, HOST/PCI, RD890 PCI to PCI bridge (external gfx0 port B)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4098:23062:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port B)
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:43624:6023:43624) pci, snd_hda_intel, MULTIMEDIA, Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
:(7023:28707:6217:28707) pci, xhci_hcd, USB, N/A
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:17315:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:17308:6217:17308) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:6217:17285) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:6217:17309) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:6217:30866) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:6217:17305) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4332:33128:6217:33128) pci, r8169, ETHERNET, Motherboard (one of many)
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:26425:5963:57716) pci, fglrx_pci, VIDEO, Barts PRO [ATI Radeon HD 6800 Series]
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:26849:6023:12288) pci, fglrx_pci, VIDEO, Manhattan [Mobility Radeon HD 5430 Series]
:(4098:23068:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port H)
:(4098:23064:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port D)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 44702012 37189621 34951682 11190272 10967446 10967446
:/dev/sdb2 WITHHELD vfat 2048 2048 2088983 186637 186637 0 0 0
:/dev/sdb1 WITHHELD fuseblk UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN
:

var_log_messages:
:Apr 15 05:25:39 Tim abrt[8515]: Saved core dump of pid 3402 (/usr/bin/gnome-shell) to /var/spool/abrt/ccpp-2012-04-15-05:25:37-3402 (220930048 bytes)
:Apr 15 05:25:39 Tim gnome-session[1490]: WARNING: Application 'gnome-shell.desktop' killed by signal
:Apr 15 07:02:18 Tim kernel: [31036.605245] gnome-shell[8519]: segfault at 39 ip 000000322541fe05 sp 00007fffb07eb068 error 4 in libcogl.so.5.0.1[3225400000+74000]
:Apr 15 07:02:20 Tim abrt[9149]: Saved core dump of pid 8519 (/usr/bin/gnome-shell) to /var/spool/abrt/ccpp-2012-04-15-07:02:18-8519 (186191872 bytes)
:Apr 15 07:02:20 Tim gnome-session[1490]: WARNING: Application 'gnome-shell.desktop' killed by signal
Comment 1 Tim Zorn 2012-04-15 07:05:48 EDT
Created attachment 577507 [details]
File: dso_list
Comment 2 Tim Zorn 2012-04-15 07:05:50 EDT
Created attachment 577508 [details]
File: build_ids
Comment 3 Tim Zorn 2012-04-15 07:05:51 EDT
Created attachment 577509 [details]
File: maps
Comment 4 Tim Zorn 2012-04-15 07:05:53 EDT
Created attachment 577510 [details]
File: xsession_errors
Comment 5 Tim Zorn 2012-04-15 07:05:55 EDT
Created attachment 577511 [details]
File: backtrace
Comment 6 Gilboa Davara 2012-04-29 07:06:00 EDT
Seeing more-or-less the same on a VM *host* w/ nVidia drivers.

gnome-shell[3101]: segfault at 58 ip 00000034c9a443e5 sp 00007fffd3c6cb38 error 4 in libcogl.so.5.0.1[34c9a00000+74000]
Comment 7 Gilboa Davara 2012-04-29 07:11:40 EDT
Please ignore, switching to nouveau solves the problem.

- Gilboa
Comment 8 Owen Taylor 2012-04-30 10:39:47 EDT
Interestingly, in retrospect, this was a very clear backtrace showing the root cause of bug 702257 - but because it by chance crashed at a different and informative place compared to the duplicates, it didn't get duplicated on that bug.

Gilboa: Don't think the nvidia proprietary crash was related unless you actually got line number information.

*** This bug has been marked as a duplicate of bug 702257 ***

Note You need to log in before you can comment on or make changes to this bug.