Bug 812644 - The display manager bugs and the system can not boot
The display manager bugs and the system can not boot
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 12:59 EDT by Joël Tang
Modified: 2012-06-02 13:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 13:26:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemcl status prefdm.service (296 bytes, text/plain)
2012-04-16 16:05 EDT, Joël Tang
no flags Details

  None (edit)
Description Joël Tang 2012-04-15 12:59:48 EDT
Description of problem:

After the installation (and the post-configuration), when Fedora boots, it bugs often, by stopping on the starting up of Sendmail. Having removed Sendmail, the screen jams on the starting up of display manager (Gnome).

Version-Release number of selected component (if applicable):

Fedora 16.

How reproducible:

Just by rebooting.

Steps to Reproduce:
1. Install Fedora.
2. Configure Fedora.
3. Reboot.
  
Actual results:

The display manager seems to stop the booting. Fedora can't boot.

Expected results:

Fedora should boot.

Additional info:
Comment 1 Lennart Poettering 2012-04-16 13:54:36 EDT
Please provide the output of the boot when you add "systemd.log_level=debug systemd.log_target=kmsg" to the kernel cmdline.

Does this continue to boot if you wait 10min?

Are you sure it actually freezes during boot? If you press Enter, do you get a login prompt? Is there a login prompt on A-F2?
Comment 2 Joël Tang 2012-04-16 14:07:52 EDT
Sorry, I don't know what is the "kernel cmdline".

No, Fedora doesn't boot, but there is a login prompt on ALT+F2.
Comment 3 Lennart Poettering 2012-04-16 14:30:50 EDT
The kernel cmdline is the command line of the kernel. You can alter it in grub by editing the kernel you want to start.

If you log in on A-F2, can you paste what "systemctl list-jobs" and "systemctl status prefdm.service" say?
Comment 4 Joël Tang 2012-04-16 15:59:01 EDT
Apparently, the kernel cmdline changes nothing.

Concerning the commands :
- systemctl list-jobs : "0 jobs listed".
- systemctl status prefdm.service : I will submit an attachment.
Comment 5 Joël Tang 2012-04-16 16:05:10 EDT
Created attachment 577822 [details]
systemcl status prefdm.service
Comment 6 Lennart Poettering 2012-04-16 16:44:52 EDT
Hmm, so gdm works fine, and no jobs are queued, so everything is is perfectly fine AFAICS.

Hmm, so can you explain again what exactly you think isn't working?
Comment 7 Joël Tang 2012-04-16 16:50:33 EDT
I do not know exactly, because I do a lot of things right after installation. Installing Flash can it affect this problem ?
Comment 8 Joël Tang 2012-04-16 16:54:48 EDT
I note that during the first round of updates, SELinux blocks access to /etc/ldconfig to /etc/shells.
Comment 9 Joël Tang 2012-04-16 20:19:34 EDT
New problem. After reinstalling Fedora, Xorg starts, but an error message appears : "Oh no! Something has gone wrong. A problem has occured and the system can't recover. Please contact a system administrator".

I think this bug doesn't exist with other graphic environments (XFCE, etc.). Only GNOME doesn't work.
Comment 10 Michal Schmidt 2012-04-17 06:54:04 EDT
> Active: active (running) since Wed, 02 Jan 2008 13:53:22 +0100, 4 years and 3 months ago

Your system clock seems to be somewhat quirky.
And the output does not show any Xorg process, so it may be X that's having trouble starting. Check /var/log/Xorg.0.log for errors.

> I do not know exactly, because I do a lot of things right after installation.
> Installing Flash can it affect this problem ?

If the problem appears only after doing a lot of things, it is reasonable to assume one of the things causes it.
I don't know about Flash.

What is the hardware (especially the graphics card) in the machine? Do you 
install any 3rd party drivers?
Comment 11 Joël Tang 2012-04-17 08:38:13 EDT
I am not mistaken with time, which is normally synchronized via NTP.

I did not install 3rd party drivers. My GPU is an APU (CPU + GPU) : AMD A6-3650. I have already discussed my problem, it seems that my hardware is only compatible with VESA.

Note You need to log in before you can comment on or make changes to this bug.