Bug 812706 - Disk image inspection failed for freeBSD guest
Disk image inspection failed for freeBSD guest
Status: CLOSED DUPLICATE of bug 541618
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 22:55 EDT by Qunfang Zhang
Modified: 2012-04-16 03:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 03:35:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2012-04-15 22:55:40 EDT
Description of problem:
Install a freeBSD 9.0 guest for either 32bit or 64 bit. After installed successfully, using virt-inspector command to identify the disk image, but can not output some related content.

Version-Release number of selected component (if applicable):
kernel-3.3.0-1.fc17.x86_64
libguestfs-1.17.26-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a freeBSD 9.0 guest.
2. After finish installation successfully: 
# virt-inspector /var/lib/libvirt/images/FreeBSD-9.0-64.qcow2 
3.
  
Actual results:
[root@localhost images]# virt-inspector /var/lib/libvirt/images/FreeBSD-9.0-64.qcow2 
<?xml version="1.0"?>
<operatingsystems/>


Expected results:
After step 2, should output an XML document containing an <operatingsystem> element and the following child elements

    * <name>
    * <distro>
    * <arch>
    * <major_version> + <minor_version>
    * <format>installed</installer> 

Additional info:
Comment 1 Richard W.M. Jones 2012-04-16 03:35:02 EDT
"<operatingsystems/>" means we found no operating systems.

There are two fundamental problems with detecting FreeBSD guests.

(1) The Linux kernel doesn't understand the BSD partition scheme
properly.

(2) The "UFS" filesystem used by BSD guests has many variants,
which aren't easily distinguished on disk, and the Linux UFS
driver requires special flags where you tell it what filesystem
variant you are trying to mount.  We don't have that information
so we cannot pass the right flag.

*** This bug has been marked as a duplicate of bug 541618 ***

Note You need to log in before you can comment on or make changes to this bug.