Bug 812728 - boost_thread does not work with gcc 4.7
boost_thread does not work with gcc 4.7
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 754865 760610
  Show dependency treegraph
 
Reported: 2012-04-16 02:00 EDT by Braden McDaniel
Modified: 2015-05-04 21:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 01:43:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2012-04-16 02:00:38 EDT
Description of problem:
Attempting to compile a program using Boost.Thread with gcc 4.7 on Fedora 17 produces error messages like this:

In file included from /home/braden/include/boost/thread/detail/platform.hpp:17:0,
                 from /home/braden/include/boost/thread/thread.hpp:12,
                 from /home/braden/include/boost/thread.hpp:13,
                 from conftest.cpp:28:
/home/braden/include/boost/config/requires_threads.hpp:29:4: error: #error "Threading support unavaliable: it has been explicitly disabled with BOOST_DISABLE_THREADS"


Version-Release number of selected component (if applicable):
1.48.0-9.fc17

How reproducible:
Consistently.
Comment 1 Braden McDaniel 2012-04-16 02:02:14 EDT
This appears to have an upstream fix:

https://svn.boost.org/trac/boost/ticket/6165

In the absence of an upgrade to 1.49.0, it would be nice to backport this.
Comment 2 Petr Machata 2012-04-16 08:39:40 EDT
We already carry that patch.  Something else must be broken.  I'll look inside.
Comment 3 Braden McDaniel 2012-04-19 02:07:26 EDT
Nevermind. I had a version of Boost installed in my home directory that I'd completely forgotten about. (Closer inspection of the output I pasted suggests as much.) I'm not seeing the problem with the current version of Fedora 17's boost package.
Comment 4 Paul Wouters 2012-07-23 17:40:54 EDT
Weird. because I just ran into this on F17 with boost-1.48.0-13
Comment 5 Renich Bon Ciric 2013-01-30 11:16:25 EST
Same on Fedora 18. I will reopen the bug.
Comment 6 Braden McDaniel 2013-02-04 01:43:26 EST
You might be seeing the same error message; however, it is either for completely different reasons than led to this report, or you're doing something as silly as I was.

In the former case, you should file a new report.
Comment 7 Thibault North 2013-04-20 21:08:34 EDT
Any update about that ?
The issue is still here on F18, boost 1.50.0.
Comment 8 Denis Arnaud 2013-04-21 02:36:47 EDT
That bug is closed. Could you re-create a bug giving more details, for instance with a minimalist program (C++ source code and Makefile) reproducing the error?
Comment 9 Thibault North 2013-04-22 13:22:40 EDT
Thanks for your answer. I updated the program that was producing this error, and it now works well.
Thanks, and sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.