Bug 812733 - headpin cli system command subscribe option does not allow multiple quantity of same subscriptions assigned
headpin cli system command subscribe option does not allow multiple quantity ...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Tazim Kolhar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 02:27 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 13:38:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-04-16 02:27:04 EDT
Description of problem:
headpin cli system command does not allow to assign multiple
quantity of same subscription to a system
Version-Release number of selected component (if applicable):
katello-headpin-0.1.145-1.el6.noarch

How reproducible:
yum install -y katello-headpin-all
katello-configure --deployment headpin


Steps to Reproduce:
1.yum install -y katello-headpin-all
2.katello-configure --deployment headpin
3.headpin -u admin -p admin system --name <sysname> --org <orgname>
--pool <poolid> --quantity <quantity>
  
Actual results:
[root@kvm-guest-04 ~]# headpin -u admin -p admin system subscribe --org ACME_Corporation --pool 8a90c51736a07d940136ab5eb8710043 --name ibm-hs22-03.rhts.eng.brq.redhat.com --quantity=3

Multi-entitlement not supported for pool with id '8a90c51736a07d940136ab5eb8710043'.

[root@kvm-guest-04 ~]# headpin -u admin -p admin system subscribe --org ACME_Corporation --pool 8a90c51736a07d940136ab5eb8710043 --name ibm-hs22-03.rhts.eng.brq.redhat.com --quantity=2

Multi-entitlement not supported for pool with id '8a90c51736a07d940136ab5eb8710043'.

[root@kvm-guest-04 ~]# headpin -u admin -p admin system subscribe --org ACME_Corporation --pool 8a90c51736a07d940136ab5eb8710043 --name ibm-hs22-03.rhts.eng.brq.redhat.com --quantity=1

Successfully subscribed System [ ibm-hs22-03.rhts.eng.brq.redhat.com ]

[root@kvm-guest-04 ~]# headpin -u admin -p admin org subscriptions --name ACME_Corporation
--------------------------------------------------------------------------------
                          Organization's Subscriptions
--------------------------------------------------------------------------------

ProductName:    High-Availability (8 sockets)
Consumed:       0
ContractNumber: 2828248
Sla:            
Id:             8a90c51736a07d940136b9bac0fc00b3
StartDate:      2012/01/02 05:00:00
EndDate:        2013/01/02 04:59:59


ProductName:    Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)
Consumed:       0
ContractNumber: 2828243
Sla:            
Id:             8a90c51736a07d940136ab83f3d2005a
StartDate:      2012/01/30 05:00:00
EndDate:        2013/01/30 04:59:59


ProductName:    High-Availability (8 sockets)
Consumed:       1
ContractNumber: 2828248
Sla:            
Id:             8a90c51736a07d940136ab5eb8710043
StartDate:      2012/01/02 05:00:00
EndDate:        2013/01/02 04:59:59


ProductName:    Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)
Consumed:       1
ContractNumber: 2828243
Sla:            
Id:             8a90c51736a07d940136ab5eb7f30035
StartDate:      2012/01/30 05:00:00
EndDate:        2013/01/30 04:59:59




Expected results:
assigning multiple quantity of subscriptions to a system should be possible
using --quantity option

Additional info:
Comment 2 RHEL Product and Program Management 2012-04-16 02:34:16 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-04-16 02:53:42 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 4 Eric Sammons 2012-04-25 13:38:54 EDT
This is not a bug with this product; please test again with a supported stackable product (i.e. RHEL 6 for 2cpu Qty 2 applied to a single RHEL 6 4 cpu system).

ProductName:    High-Availability (8 sockets)
Consumed:       1
ContractNumber: 2828248
Sla:            
Id:             8a90c51736a07d940136ab5eb8710043

Only supports Qty 1 on this particular system.

Note You need to log in before you can comment on or make changes to this bug.