Bug 812740 - Unable to delete the images under a deleted cloud
Unable to delete the images under a deleted cloud
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 02:49 EDT by Shveta
Modified: 2012-12-04 10:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Images within a provider account or cloud were left unassigned if the cloud or provider account was deleted. This update adds a warning message when attempting to delete a cloud with images.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:03:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dangling images (207.06 KB, image/png)
2012-04-16 02:49 EDT, Shveta
no flags Details

  None (edit)
Description Shveta 2012-04-16 02:49:17 EDT
Created attachment 577643 [details]
dangling images

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce: 
1. Created a cloud CLoud_shv and created some images under it as non admin user
2. Next i deleted this cloud as admin.
3. images shows N/A under cloud ( fine ) but there is no way to delete such images as shown in the attached screenshot.
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
Comment 1 Jan Provaznik 2012-08-29 11:02:42 EDT
There are more options how to fix this:
1) don't allow delete provider accounts and providers which have built/pushed images and dysplay warning that these images should be deleted first
2) auto-destroy images when associated provider account is deleted
3) don't delete images when associated provider account is deleted, but show them on image build page and allow to delete them

I would suggest option 1) - it's easy to implement and quite clean.
Comment 2 Angus Thomas 2012-08-31 05:42:06 EDT
Option 1 looks good for the 1.1 release.
Comment 3 Jan Provaznik 2012-09-05 08:05:22 EDT
pushed in master, commit: 2628b0019825eae76439e05e1b000015f50b7b13
pushed in 1.1, commit: 6981c543cadcba94776e13589c6caa80fc794ddc

patch in 1.1 was not cherry-picked from master but pushed directly because patch in master is slightly different.
Comment 4 Steve Linabery 2012-09-07 17:52:46 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 6 Rehana 2012-09-21 11:06:04 EDT
Now displayed warning message "There are following associated images: rhel62_rhem, imp-rhevm. Delete them first." when tried to delete a cloud with images

moving to verified 

 rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:03:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.