Bug 812794 - cobbler-2.2.1-1.el6 - cobbler-setup fails with traceback
cobbler-2.2.1-1.el6 - cobbler-setup fails with traceback
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
: 812380 (view as bug list)
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-16 05:12 EDT by Lukas Pramuk
Modified: 2012-11-01 12:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 12:18:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Pramuk 2012-04-16 05:12:23 EDT
Description of problem:
cobbler-setup fails with traceback.

It seems that some configuration templates (/usr/share/cobbler/installer_templates/defaults) were dropped with new version of cobbler. Though cobbler-setup still tries to access them.

Version-Release number of selected component (if applicable):
cobbler 2.2.1-1.el6

How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/cobbler-setup 
2. got traceback
  
Actual results:
cobbler-setup fails 

Expected results:
cobbler-setup run successfully

Additional info:
[root@host ~]# /usr/bin/cobbler-setup 
Traceback (most recent call last):
  File "/usr/bin/cobbler-setup", line 78, in <module>
    main()
  File "/usr/bin/cobbler-setup", line 55, in main
    answers = dict(loadFile(DEFAULTS))
  File "/usr/bin/cobbler-setup", line 26, in loadFile
    return load(open(fl).read())
IOError: [Errno 2] No such file or directory: '/usr/share/cobbler/installer_templates/defaults'
Comment 1 Milan Zázrivec 2012-04-24 08:46:17 EDT
spacewalk.git master:

b876b9d0e1fdb186a2e758a880e38e086735fca3
f467a5b2473f8da01544b115217d98653da828f5
87d4fed998c5b354bb74a6f024d15c4942e9b325
Comment 2 Milan Zázrivec 2012-04-24 10:01:51 EDT
*** Bug 812380 has been marked as a duplicate of this bug. ***
Comment 3 Jan Pazdziora 2012-10-30 15:23:41 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 4 Jan Pazdziora 2012-11-01 12:18:57 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.