Bug 812795 - Process mount.ntfs waiting for something when I plug NTFS formatted usb stick.
Process mount.ntfs waiting for something when I plug NTFS formatted usb stick.
Status: CLOSED DUPLICATE of bug 812798
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
17
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 05:13 EDT by Mikhail
Modified: 2012-10-05 02:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 16:51:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system monitor (71.73 KB, image/png)
2012-04-16 05:16 EDT, Mikhail
no flags Details
disk utility (62.90 KB, image/png)
2012-04-16 08:33 EDT, Mikhail
no flags Details
strace -o mount.ntfs.strace /sbin/mount.ntfs /dev/sda2 /mnt -o ro,norecover,no_detach,debug (12.64 KB, text/plain)
2012-04-16 16:38 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mikhail 2012-04-16 05:13:08 EDT
Description of problem:
Process mount.ntfs waiting for something when I plug NTFS formatted usb stick.
Comment 1 Mikhail 2012-04-16 05:16:20 EDT
Created attachment 577669 [details]
system monitor
Comment 2 Mikhail 2012-04-16 05:28:56 EDT
$ dmesg
[ 3257.957127] scsi 9:0:0:0: Direct-Access     JetFlash Transcend 16GB   1100 PQ: 0 ANSI: 0 CCS
[ 3257.963100] sd 9:0:0:0: Attached scsi generic sg1 type 0
[ 3257.964186] sd 9:0:0:0: [sdb] 31703040 512-byte logical blocks: (16.2 GB/15.1 GiB)
[ 3257.964903] sd 9:0:0:0: [sdb] Write Protect is off
[ 3257.964911] sd 9:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 3257.965659] sd 9:0:0:0: [sdb] No Caching mode page present
[ 3257.965667] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 3257.969764] sd 9:0:0:0: [sdb] No Caching mode page present
[ 3257.969769] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 3257.972920]  sdb: sdb1
[ 3257.975891] sd 9:0:0:0: [sdb] No Caching mode page present
[ 3257.975897] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 3257.975901] sd 9:0:0:0: [sdb] Attached SCSI removable disk
Comment 3 Jean-Pierre André 2012-04-16 08:19:26 EDT
Can you post the outputs of :
uname -a
ntfs-3g --help 2>&1 --help | head -n 4
ls -l /dev/fuse
ps -eaf | grep fuse
# the following, as root, with the usb key inserted
ntfsfix -n /dev/sdb1
Comment 4 Mikhail 2012-04-16 08:30:03 EDT
mikhail@ao521:~$ uname -a
Linux ao521 3.3.1-5.fc17.i686.PAE #1 SMP Tue Apr 10 21:06:28 UTC 2012 i686 i686 i386 GNU/Linux
mikhail@ao521:~$ ntfs-3g --help 2>&1 --help | head -n 4

ntfs-3g 2012.1.15 integrated FUSE 27 - Third Generation NTFS Driver
		Configuration type 1, XATTRS are on, POSIX ACLS are off

mikhail@ao521:~$ ls -l /dev/fuse
crw-rw-rw-. 1 root root 10, 229 апр.  16 14:30 /dev/fuse
mikhail@ao521:~$ ps -eaf | grep fuse
mikhail    984     1  0 14:30 ?        00:00:00 /usr/libexec//gvfs-fuse-daemon -f /run/user/mikhail/gvfs
root       988   984  0 14:30 ?        00:00:00 fusermount -o rw,nosuid,nodev,subtype=gvfs-fuse-daemon -- /run/user/mikhail/gvfs
mikhail   4710  2997  0 18:27 pts/0    00:00:00 grep --color=auto fuse
mikhail@ao521:~$ sudo ntfsfix -n /dev/sdb1
[sudo] password for mikhail: 
Mounting volume... Failed to read lock '/dev/sdb1': Resource temporarily unavailable
Error opening '/dev/sdb1': Resource temporarily unavailable
FAILED
Attempting to correct errors... Failed to read lock '/dev/sdb1': Resource temporarily unavailable
Error opening '/dev/sdb1': Resource temporarily unavailable
FAILED
Failed to startup volume: Resource temporarily unavailable
Failed to read lock '/dev/sdb1': Resource temporarily unavailable
Error opening '/dev/sdb1': Resource temporarily unavailable
Volume is corrupt. You should run chkdsk.
No change made
Comment 5 Mikhail 2012-04-16 08:33:59 EDT
Created attachment 577700 [details]
disk utility
Comment 6 Mikhail 2012-04-16 08:41:00 EDT
mikhail@ao521:~$ ps ax | grep mount
  988 ?        S      0:00 fusermount -o rw,nosuid,nodev,subtype=gvfs-fuse-daemon -- /run/user/mikhail/gvfs
 4765 ?        S      0:00 mount -t ntfs -o uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177 /dev/sdb1 /run/media/mikhail/Transcend
 4766 ?        S      0:00 /sbin/mount.ntfs /dev/sdb1 /run/media/mikhail/Transcend -o rw,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177,uhelper=udisks2
 4858 pts/0    S+     0:00 grep --color=auto mount
mikhail@ao521:~$ sudo kill -9 4766
[sudo] password for mikhail: 
mikhail@ao521:~$ sudo ntfsfix -n /dev/sdb1
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.
mikhail@ao521:~$
Comment 7 Jean-Pierre André 2012-04-16 08:54:47 EDT
Then, after having killed the mount process as you did above, can you mount manually as root, into an existing directory :
mount -t ntfs -o ro /dev/sdb1 existing-mount-point
Comment 8 Mads Kiilerich 2012-04-16 16:38:56 EDT
Created attachment 577831 [details]
strace -o mount.ntfs.strace /sbin/mount.ntfs /dev/sda2 /mnt -o ro,norecover,no_detach,debug

I just started seeing something like this, so I guess it has been caused by some recent update.

ntfs-3g fuse kernel-PAE
ntfs-3g-2012.1.15-1.fc17.i686
fuse-2.8.6-4.fc17.i686
kernel-PAE-3.3.1-5.fc17.i686

[root@dev-mk ~]# ntfsfix /dev/sda2
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.

[root@dev-mk ~]# strace -o mount.ntfs.strace /sbin/mount.ntfs /dev/sda2 /mnt -o ro,norecover,no_detach,debug
Killed

[root@dev-mk ~]# ps -fed|grep '[n]tfs' || echo none
none
Comment 9 Tom "spot" Callaway 2012-04-16 16:51:30 EDT

*** This bug has been marked as a duplicate of bug 812798 ***
Comment 10 Mikhail 2012-04-17 00:12:27 EDT
The worstest in this case that while the process mount.ntfs is hanging other devices are not recognized. Here's an example I connected 3G modem. While I did not kill mount.ntfs he did not want to be defined.


[16286.732046] usb 2-2: new high-speed USB device number 9 using ehci_hcd
[16286.921300] usb 2-2: New USB device found, idVendor=8564, idProduct=1000
[16286.921307] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[16286.921311] usb 2-2: Product: Mass Storage Device
[16286.921315] usb 2-2: Manufacturer: JetFlash
[16286.921319] usb 2-2: SerialNumber: 85P8KCQ2A75S3WRH
[16286.922411] scsi11 : usb-storage 2-2:1.0
[16288.324206] scsi 11:0:0:0: Direct-Access     JetFlash Transcend 16GB   1100 PQ: 0 ANSI: 0 CCS
[16288.325786] sd 11:0:0:0: Attached scsi generic sg1 type 0
[16288.328546] sd 11:0:0:0: [sdb] 31703040 512-byte logical blocks: (16.2 GB/15.1 GiB)
[16288.329293] sd 11:0:0:0: [sdb] Write Protect is off
[16288.329300] sd 11:0:0:0: [sdb] Mode Sense: 43 00 00 00
[16288.330049] sd 11:0:0:0: [sdb] No Caching mode page present
[16288.330056] sd 11:0:0:0: [sdb] Assuming drive cache: write through
[16288.333287] sd 11:0:0:0: [sdb] No Caching mode page present
[16288.333292] sd 11:0:0:0: [sdb] Assuming drive cache: write through
[16288.334486]  sdb: sdb1
[16288.337175] sd 11:0:0:0: [sdb] No Caching mode page present
[16288.337183] sd 11:0:0:0: [sdb] Assuming drive cache: write through
[16288.337188] sd 11:0:0:0: [sdb] Attached SCSI removable disk
[16292.688991] usb 2-2: USB disconnect, device number 9
[16292.699032] sd 11:0:0:0: [sdb] Unhandled error code
[16292.699036] sd 11:0:0:0: [sdb]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[16292.699040] sd 11:0:0:0: [sdb] CDB: Write(10): 2a 00 00 5c 78 f8 00 00 f0 00
[16292.699048] end_request: I/O error, dev sdb, sector 6060280
[16292.699053] Buffer I/O error on device sdb1, logical block 6060248
[16292.699055] lost page write due to I/O error on sdb1
[16292.699058] Buffer I/O error on device sdb1, logical block 6060249
[16292.699060] lost page write due to I/O error on sdb1
[16292.699062] Buffer I/O error on device sdb1, logical block 6060250
[16292.699064] lost page write due to I/O error on sdb1
[16292.699066] Buffer I/O error on device sdb1, logical block 6060251
[16292.699068] lost page write due to I/O error on sdb1
[16292.699070] Buffer I/O error on device sdb1, logical block 6060252
[16292.699072] lost page write due to I/O error on sdb1
[16292.699074] Buffer I/O error on device sdb1, logical block 6060253
[16292.699076] lost page write due to I/O error on sdb1
[16292.699078] Buffer I/O error on device sdb1, logical block 6060254
[16292.699080] lost page write due to I/O error on sdb1
[16292.699082] Buffer I/O error on device sdb1, logical block 6060255
[16292.699083] lost page write due to I/O error on sdb1
[16292.699088] Buffer I/O error on device sdb1, logical block 6060256
[16292.699090] lost page write due to I/O error on sdb1
[16292.699092] Buffer I/O error on device sdb1, logical block 6060257
[16292.699094] lost page write due to I/O error on sdb1
[16292.728147] sd 11:0:0:0: [sdb] Unhandled error code
[16292.728151] sd 11:0:0:0: [sdb]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[16292.728155] sd 11:0:0:0: [sdb] CDB: Write(10): 2a 00 00 5c 79 e8 00 00 f0 00
[16292.728164] end_request: I/O error, dev sdb, sector 6060520
[19662.601503] show_signal_msg: 470 callbacks suppressed
[19662.601508] Compositor[1992]: segfault at 0 ip   (null) sp af4a68bc error 14
[24483.840535] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[27629.446130] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[27633.335602] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[85599.356284] SELinux: (dev sdb1, type fuseblk) getxattr errno 4
[85599.569063] usb 2-2: new high-speed USB device number 10 using ehci_hcd
[85599.685686] usb 2-2: New USB device found, idVendor=0502, idProduct=3223
[85599.685693] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[85599.685698] usb 2-2: Product: Android HSUSB Device
[85599.685702] usb 2-2: Manufacturer: Acer Incorporated
[85599.685705] usb 2-2: SerialNumber: 0000038460334896
[85599.691061] rndis_host 2-2:1.0: usb0: register 'rndis_host' at usb-0000:00:1d.7-2, RNDIS device, 4a:e9:c0:20:4d:99
[85615.730020] usb0: no IPv6 routers present
[mikhail@telecon17l ~]$

Note You need to log in before you can comment on or make changes to this bug.