Bug 81283 - kwin crash after login to kde
Summary: kwin crash after login to kde
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-07 16:01 UTC by bjorn mantels
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-15 16:55:47 UTC


Attachments (Terms of Use)

Description bjorn mantels 2003-01-07 16:01:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
1. I installed RH 8 from cd onto my laptop
2. Installed additional products & customized graphical environment
3. For a few days all went fine, all of a sudden kwin crashed with messages below
4. Since then, kwin crashes systematically after login into kde and the
panel etc. is loaded 

(kdebase-3.0.3-14)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start system, login to kde
2. await subsystems to be initialized (keyboard, sounds, panel, session,...)
3. when user interface starts to load : kwin crashes (and also everytime I try
to start it manually )
    

Actual Results:  see error mesages below

Expected Results:  normal startup of GUI, restore of previous session

Additional info:

(no debugging symbols found)...[New Thread 8192 (LWP 1512)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e1cc63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x4062d1e5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x414ffd90 in KWinInternal::RedHatClient::addClientButtons(QString const&,
bool) () from /usr/lib/kde3/kwin_bluecurve.so
#6  0x414ffa51 in
KWinInternal::RedHatClient::RedHatClient(KWinInternal::Workspace*, unsigned
long, QWidget*, char const*) ()
   from /usr/lib/kde3/kwin_bluecurve.so
#7  0x41502c9b in allocate () from /usr/lib/kde3/kwin_bluecurve.so
#8  0x412f91d6 in
KWinInternal::PluginMgr::allocateClient(KWinInternal::Workspace*, unsigned long,
bool) () from /usr/lib/kwin.so
#9  0x412cc411 in KWinInternal::Workspace::clientFactory(unsigned long) ()
   from /usr/lib/kwin.so
#10 0x412ce9b8 in KWinInternal::Workspace::workspaceEvent(_XEvent*) ()
   from /usr/lib/kwin.so
#11 0x412f307e in Application::x11EventFilter(_XEvent*) ()
   from /usr/lib/kwin.so
#12 0x40832bb6 in qt_x11EventFilter(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x4083c827 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#14 0x4083c52f in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x4089d280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x4083c02d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#17 0x412f3487 in kdemain () from /usr/lib/kwin.so
#18 0x0804cb9f in strcpy ()
#19 0x0804d8bb in strcpy ()
#20 0x0804dd7c in strcpy ()
#21 0x0804eb40 in strcpy ()
#22 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

Comment 1 Ngo Than 2003-02-15 16:55:47 UTC
Hmm, i cannot reproduce it on RHL 8.0. Please make sure that you have only
installed the KDE rpms from redhat 8.0.



Note You need to log in before you can comment on or make changes to this bug.