Bug 81285 - [RFE] mediacheck's importantance should be more pronounced to the end-user (about, errors, etc.)
[RFE] mediacheck's importantance should be more pronounced to the end-user (a...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
: 81284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-07 11:20 EST by Michael Lee Yohe
Modified: 2007-03-26 23:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 15:02:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-01-07 11:20:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030102

Description of problem:
As a result of some correspondence in Bug 81245, I feel that Anaconda's
mediacheck option should be a bit more aggressive to skip.  Not to say that a
user cannot proceed without checking the media, but selecting "Continue" without
checking _all_ three CDs will inform the user that installing Red Hat Linux from
CDs that have data corruption could leave the system in a completely unusable
state (for new installs and upgrades from older releases).

mediacheck should provide a fairly detailed synopsis of what it is going to
perform, how long it should take, and why it is important to be used prior to
installation or upgrade.  The average newbie just wants to stick a disc in and
auto-magically have everything work.

If the end-user opts out of checking the media by selecting "skip" (or whatever
is specified in the dialog box), Anaconda should ask for confirmation warning of
the consequences of _not_ performing a mediacheck prior to installation or upgrade.

The reporter in Bug 81245 stated that if mediacheck had mentioned about a seek
error, he would have been more likely to not use the disc.  If the checksum
retrieved from the disc does not match what Anaconda believes to be the correct
checksum, Anaconda can tell the end-user a simple message saying something like
the following:

The disc that is in the drive has some data corruption.  This could be due to a
variety of factors including a bad download, damaged media, or failed burn (if
from an ISO image).  Please clean this disc and try again, or insert a new disc
and try again.

If Anaconda believes that the disc is corrupted - it should _prevent_ the
end-user from actually installing using the disc.  Installing anyway could cause
traceback errors further down the road (after half an hour or so) - nearly
always causing frustration.

If the checksum is improper - it should be assumed that any package on the disc
may be corrupted and should not be used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description

    

Actual Results:  mediacheck is optional.  The message about testing a disc is
very basic.  You can continue the installation without checking with relative ease.

Expected Results:  mediacheck is still optional but encouraged by a confirmation
of skipping dialog box.  mediacheck should introduce itself and the problems
that can be caused by faulty media and/or corrupted data.

Additional info:
Comment 1 Michael Lee Yohe 2003-01-07 11:24:13 EST
*** Bug 81284 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2003-01-07 18:06:35 EST
Thanks for the suggestion. I've changed the message to more like what you have
in your email.  It still lets you continue even if you had some failed tests,
but honestly I have RARELY had a bad cd report where they'd tested the CD, as
the anaconda.log logs the test results and I can see this in their traceback.
Comment 3 Michael Lee Yohe 2003-01-08 08:23:48 EST
Right, Michael - I figured the standard "mediacheck" would explain the common
sense behind what it's trying to do, but apparently people actually just attempt
to assume what it's doing, continue, and break their installations.

That's cool - will try it when the new beta is released.
Comment 4 Mike McLean 2003-01-21 15:02:17 EST
New text confirmed.

Note You need to log in before you can comment on or make changes to this bug.