Bug 812865 - Kdump doesn't work after configure the remote nfs server
Kdump doesn't work after configure the remote nfs server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression
Depends On: 817157
Blocks: 823646
  Show dependency treegraph
 
Reported: 2012-04-16 09:02 EDT by shine
Modified: 2016-04-26 11:41 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 823646 (view as bug list)
Environment:
Last Closed: 2012-07-19 10:11:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KdumpDoesntWorkPictures (107.33 KB, application/x-gzip)
2012-04-16 09:02 EDT, shine
no flags Details
kdump log (2.14 KB, application/x-troff-man)
2012-04-18 02:50 EDT, shine
no flags Details

  None (edit)
Description shine 2012-04-16 09:02:25 EDT
Created attachment 577710 [details]
KdumpDoesntWorkPictures

Description of problem:
 Kdump doesn't work after configure the remote nfs server


 Version-Release number of selected component (if applicable):
 rhev-hypervisor6-6.3-20120411.1

 How reproducible:
 100%

 Steps to Reproduce:
 1. Install rhevh on local host
 2. Configure network
 3. Scroll down to Kernel Dump, choose setup nfs configuration
 4. Enter the nfs server address, and confirm the input address;[attachment RemoteNFS.png]
 5. Change to shell mode, and input "echo c > /proc/sysrq-trigger", to make the system coredump;
 6. After the system reboot, check the dump file on the remote nfs input before.

 Actual results:
 There is folder nfs:/path/var/crash in the nfs directory.
 But there is no dump file named with the dump time.
 [attachment NoDumpFile.png]

 Expected results:
 There is dump file named with the dump time in the nfs:/path/var/crash.

 Additional info:
 This a regression test.
Comment 3 shine 2012-04-17 03:50:52 EDT
ps: The kdump works well in the last build: rhev-hypervisor6-6.3-20120409.0.el6_2.
Comment 4 shine 2012-04-17 03:54:13 EDT
ps: The kdump works well in the last build: rhev-hypervisor6-6.3-20120409.0.el6_2.
Comment 5 shine 2012-04-17 03:57:22 EDT
(In reply to comment #3)
> ps: The kdump works well in the last build:
> rhev-hypervisor6-6.3-20120409.0.el6_2.

Sorry there is a mistake about the name of the last build.
It should be rhev-hypervisor6-6.3-20120330.0.el6.
Comment 6 shine 2012-04-17 03:57:49 EDT
(In reply to comment #4)
> ps: The kdump works well in the last build:
> rhev-hypervisor6-6.3-20120409.0.el6_2.

Sorry there is a mistake about the name of the last build.
It should be rhev-hypervisor6-6.3-20120330.0.el6.
Comment 8 shine 2012-04-18 02:50:05 EDT
Created attachment 578249 [details]
kdump log


The attachment Kdump6.3  is the log grabbed through serial console on two rhevh versions.
I have tried the tests on the same machine with the same nfs storage path, but the different rhevh version.
The kdump works well on the last rhevh version:  6.3-20120330.0.el6.
The kdump couldn't get a DHCP address retRestarting system on the rhevh 6.3-20120411.1; so there is no the dump file named with host-name and dump time on the nfs storage.
Comment 18 errata-xmlrpc 2012-07-19 10:11:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.