Bug 812901 - multilib conflict between libdb-devel.x86_64 and libdb-devel.i686
multilib conflict between libdb-devel.x86_64 and libdb-devel.i686
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libdb (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 10:07 EDT by Edward Sheldrake
Modified: 2013-07-02 19:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-02 08:08:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2012-04-16 10:07:36 EDT
Description of problem:
I cannot install both i686 and x86_64 libdb-devel at the same time due to one tiny conflict.

Version-Release number of selected component (if applicable):
libdb-devel-5.2.36-5.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to install libdb-devel.x86_64 and libdb-devel.i686
2.
3.
  
Actual results:
Conflict on /usr/include/libdb/db.h

Expected results:
No conflict

Additional info:
db4-devel has no conflict and contains "typedef int64_t db_seq_t;" but libdb-devel has:

diff -Nurp i686/usr/include/libdb/db.h x86_64/usr/include/libdb/db.h
--- i686/usr/include/libdb/db.h	2012-02-17 20:00:24.000000000 +0000
+++ x86_64/usr/include/libdb/db.h	2012-02-17 19:59:56.000000000 +0000
@@ -120,7 +120,7 @@ typedef ssize_t db_ssize_t;
 /*
  * Sequences are only available on machines with 64-bit integral types.
  */
-typedef long long db_seq_t;
+typedef long db_seq_t;
 
 /* Thread and process identification. */
 typedef pthread_t db_threadid_t;
Comment 1 Edward Sheldrake 2013-02-02 08:08:21 EST
Fixed in Fedora 18 and above.

Note You need to log in before you can comment on or make changes to this bug.