Bug 812914 - os-prober hangs in mount("/dev/sda2", "/var/lib/os-prober/mount", "fuseblk"
os-prober hangs in mount("/dev/sda2", "/var/lib/os-prober/mount", "fuseblk"
Status: CLOSED DUPLICATE of bug 812798
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 10:45 EDT by Mads Kiilerich
Modified: 2012-04-17 14:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 14:56:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2012-04-16 10:45:07 EDT
grub2-mkconfig hangs - because os-prober hangs.


Some mount.ntfs processes were hanging. After killing them hardly I can do:

[root@dev-mk ~]# mount /dev/sda2 /mnt
The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.

- and it will hang.


I would expect os-prober to do probing in such a way that external failing or hanging tools didn't stop the probing ... and if other tools are considered essential then it should show the output from them so debugging was possible.


os-prober-1.51-1.fc17.i686
fuse-2.8.6-4.fc17.i686
ntfs-3g-2012.1.15-1.fc17.i686
kernel-PAE-3.3.0-8.fc17.i686 or kernel-PAE-3.3.1-5.fc17.i686
Comment 1 Hedayat Vatankhah 2012-04-16 11:10:31 EDT
IMHO it is too unrealistic to expect os-prober to be prepared that "every external program might hang"! Maybe mount.ntfs is really not expected to hang and a bug against it instead?

Another thing which comes to my mind is to mount partitions read only. It might prevent mount.ntfs from trying to fix the problem completely as I can see in its man page. If your partition is still unclean, can you try mount with -o ro option to see if it doesn't hang?
Comment 2 Pytela, Zdenek 2012-04-17 09:52:31 EDT
I can confirm this behaviour, similar situation but
fuse-2.8.7-1.fc17.x86_64
kernel-3.3.2-1.fc17.x86_64

Partition was unmounted cleanly, but now it cannot be mounted even read only:
mount.ntfs -o ro /dev/sda1 /mnt
hangs (10+ minutes) in fuse_get_req.

In f16 os-prober and mount work as expected.
Comment 3 Hedayat Vatankhah 2012-04-17 14:50:42 EDT
I really think that this bug should be assigned to ntfs-3g or fuse rather than os-prober.
Comment 4 Tom "spot" Callaway 2012-04-17 14:56:14 EDT

*** This bug has been marked as a duplicate of bug 812798 ***

Note You need to log in before you can comment on or make changes to this bug.