Bug 812918 - Supend no longer works
Supend no longer works
Status: CLOSED DUPLICATE of bug 812588
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 10:52 EDT by Brian G. Anderson
Modified: 2012-04-17 13:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 13:42:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suspend log (5.41 KB, text/x-log)
2012-04-16 10:53 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2012-04-16 10:52:06 EDT
Description of problem:
After upgrade to kernel 3.3.1 suspend no longer works.  I've attached the pm-suspend log though I don't see any obvious problems.

Version-Release number of selected component (if applicable):
kernel-3.3.1-5.fc17.x86_64 (fail)
kernel-3.3.0-1.fc17.x86_64 (works)


How reproducible:
every time

Steps to Reproduce:
1.boot
2.try and suspend with close lid, use suspend menu selection, or pm-suspend
3.
  
Actual results:
Screen goes blank and network manager stops, but the computer is still on.  when you move the mouse the screensaver password prompt appears

Expected results:
suspend

Additional info:
I'm using a Dell Lattitude E6140
Comment 1 Brian G. Anderson 2012-04-16 10:53:35 EDT
Created attachment 577733 [details]
suspend log
Comment 2 Michal Ambroz 2012-04-17 12:55:43 EDT
Hello,
I have got same issue since todays' "yum -y update".
Different notebook: HP EliteBook 6930p

I believe it is not directly the kernel causing it but maybe some other package.
After update I have found about this issue and tried with last 2 kernel versions, which were working before, but none of them works anymore.
Problematic package was installed somewhere between 8-Apr and 17-Apr.

kernel-3.3.2-1.fc17.x86_64 (not working)
kernel-3.3.1-5.fc17.x86_64 (not working)
kernel-3.3.1-3.fc17.x86_64 (Was working since 6Apr till yesterday 16Apr, not working now)
kernel-3.3.0-8.fc17.x86_64 (Was working on 4-Apr during the pm-test-day, not working now)


If I try to run pm-suspend it hangs forever.
This is the output of "strace pm-suspend": 
write(1, "Tue Apr 17 18:46:55 CEST 2012: p"..., 50) = 50
stat(".", {st_mode=S_IFDIR|0550, st_size=4096, ...}) = 0
stat("/sbin/sync", 0x7fffd8aa6700)      = -1 ENOENT (No such file or directory)
stat("/usr/sbin/sync", 0x7fffd8aa6700)  = -1 ENOENT (No such file or directory)
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
geteuid()                               = 0
getegid()                               = 0
getuid()                                = 0
getgid()                                = 0
access("/bin/sync", X_OK)               = 0
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
geteuid()                               = 0
getegid()                               = 0
getuid()                                = 0
getgid()                                = 0
access("/bin/sync", R_OK)               = 0
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
geteuid()                               = 0
getegid()                               = 0
getuid()                                = 0
getgid()                                = 0
access("/bin/sync", X_OK)               = 0
stat("/bin/sync", {st_mode=S_IFREG|0755, st_size=27288, ...}) = 0
geteuid()                               = 0
getegid()                               = 0
getuid()                                = 0
getgid()                                = 0
access("/bin/sync", R_OK)               = 0
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [INT CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [INT CHLD], NULL, 8) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f68e2dc2a10) = 10444
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {0x43e650, [], SA_RESTORER, 0x32cb635990}, {0x4566f0, [], SA_RESTORER, 0x32cb635990}, 8) = 0
wait4(-1,




That write in the strace is "Tue Apr 17 18:46:55 CEST 2012: performing suspend" from the /var/log/pm-suspend.log

And then it hangs forever.

NeworkManager gets to suspend all the network cards and never comes back.
You need to "service NetworkManager restart" to regain the network connectivity.

Best regards
Michal Ambroz
Comment 3 Brian G. Anderson 2012-04-17 13:05:04 EDT
Yes,  I went back and checked and kernels that used to suspend don't anymore.  I even switched to the 3.3.2 kernel and same result.

As #2 says,  I don't think it is the kernel, but I cannot find what is stopping the suspend.
Comment 4 Josh Boyer 2012-04-17 13:08:23 EDT
This sounds like bug 812588
Comment 5 Brian G. Anderson 2012-04-17 13:42:02 EDT
Yup,  I installed https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-116.fc17 and suspend now works.  I'm marking this as duplicate
Comment 6 Brian G. Anderson 2012-04-17 13:42:30 EDT

*** This bug has been marked as a duplicate of bug 812588 ***

Note You need to log in before you can comment on or make changes to this bug.