Bug 812929 - Firstboot: Register with auto-subscribe for the cert 27060.pem throws error message
Summary: Firstboot: Register with auto-subscribe for the cert 27060.pem throws error m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Shwetha Kallesh
QA Contact: Entitlement Bugs
URL:
Whiteboard:
: 814137 (view as bug list)
Depends On:
Blocks: 738066
TreeView+ depends on / blocked
 
Reported: 2012-04-16 15:22 UTC by Shwetha Kallesh
Modified: 2012-06-20 13:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Red Hat Enterprise Linux 6.3 Beta release includes a bug which effects accounts which contain subscriptions with more than a single Service Level Agreement (that is, contains both Basic and Premium Subscriptions). Customers who have multiple service levels should choose to not auto-subscribe when registering with subscription-manager; instead, use the All Available Subscriptions tab.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:09:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unable to register (121.94 KB, image/png)
2012-04-16 15:52 UTC, Shwetha Kallesh
no flags Details
log showing the error (1.74 KB, text/plain)
2012-04-17 17:24 UTC, Adrian Likins
no flags Details
more logs (6.06 KB, text/plain)
2012-04-17 18:58 UTC, Adrian Likins
no flags Details
Registers with auto-subscribe (114.11 KB, image/png)
2012-04-26 08:11 UTC, Shwetha Kallesh
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 0 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 19:51:31 UTC

Description Shwetha Kallesh 2012-04-16 15:22:15 UTC
Description of problem:

Firstboot: Register with auto-subscribe with the cert 27060.pem throws error message

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1) etc/pki/product/27060.pem
2)firstboot -r
3)Enter the details in the entitlement registration platform
4) DoNOT skip the auto-subscribe

  
Actual results:
in the attachment

Expected results:
Should register and auto-subscribe without error

Additional info:

Comment 2 Shwetha Kallesh 2012-04-16 15:52:52 UTC
Created attachment 577748 [details]
Unable to register

Comment 3 Adrian Likins 2012-04-17 17:24:52 UTC
Created attachment 578113 [details]
log showing the error

Comment 4 Adrian Likins 2012-04-17 17:26:03 UTC
traceback in line for easy viewing...

git RHEL6.3 with 27060.pem against master candlepin

firstboot DEBUG: Service level does not cover required products: Premium
firstboot ERROR: 'Premium'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 295, in _on_registration_finished_cb
    self._finish_registration()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 231, in _finish_registration
    self._init_sla()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_login.py", line 282, in _init_sla
    self.interface.moveToPage(moduleTitle=_("Confirm Subscriptions"))
  File "/usr/lib/python2.6/site-packages/firstboot/interface.py", line 412, in moveToPage
    self.displayModule()
  File "/usr/lib/python2.6/site-packages/firstboot/interface.py", line 335, in displayModule
    currentModule.initializeUI()
  File "/usr/share/rhn/up2date_client/firstboot/rhsm_confirm_subs.py", line 87, in initializeUI
    controller.suitable_slas[controller.selected_sla])
KeyError: 'Premium'

Comment 5 Adrian Likins 2012-04-17 18:58:43 UTC
Created attachment 578131 [details]
more logs

Closer inspection of the output shows that we are running dryrun for
Standard and Premium, and it's showing Premium is not a working service
level, but it's trying to use it anyway

Comment 6 Michael Stead 2012-04-19 14:34:23 UTC
Fix committed in master and RHEL6.3 branches.

RHEL6.3:
 commit: d5e53bc5f4da51c353d935334a0b4d5dc1dfa0a6
 available: subscription-manager-0.99.15-1+

master:
 commit: 1d1ef825e464963c0376fb244a914474c983279d
 available: subscription-manager-1.0.0-1+

Comment 8 Michael Stead 2012-04-20 14:32:23 UTC
*** Bug 814137 has been marked as a duplicate of this bug. ***

Comment 11 Bryan Kearney 2012-04-23 18:14:59 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The Beta release includes a bug which effects accounts which contains subscriptions with more that an a single Service Level Agreement (i.e. contains both Basic and Premium Subscriptions). Customers who have multiple service levels should choose to not auto-subscribe when registering with subscription-manager. Instead, they should use the "All Available Subscriptions" tab.

Comment 13 Martin Prpič 2012-04-23 18:27:50 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The Beta release includes a bug which effects accounts which contains subscriptions with more that an a single Service Level Agreement (i.e. contains both Basic and Premium Subscriptions). Customers who have multiple service levels should choose to not auto-subscribe when registering with subscription-manager. Instead, they should use the "All Available Subscriptions" tab.+The Red Hat Enterprise Linux 6.3 Beta release includes a bug which effects accounts which contain subscriptions with more than a single Service Level Agreement (that is, contains both Basic and Premium Subscriptions). Customers who have multiple service levels should choose to not auto-subscribe when registering with subscription-manager; instead, use the All Available Subscriptions tab.

Comment 16 Shwetha Kallesh 2012-04-26 08:11:09 UTC
Created attachment 580403 [details]
Registers with auto-subscribe

Verified!!

Version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-0.99.15-1.el6.x86_64
subscription-manager-migration-0.99.15-1.el6.x86_64
subscription-manager-firstboot-0.99.15-1.el6.x86_64
subscription-manager-gnome-0.99.15-1.el6.x86_64
subscription-manager-debuginfo-0.99.15-1.el6.x86_64
subscription-manager-migration-data-1.12.1.5-1.el6.noarch

Comment 18 errata-xmlrpc 2012-06-20 13:09:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html


Note You need to log in before you can comment on or make changes to this bug.