Bug 813060 - cannot mount NTFS media - mount fusectl on /sys/fs/fuse/connections failed: Operation not supported
cannot mount NTFS media - mount fusectl on /sys/fs/fuse/connections failed: O...
Status: CLOSED DUPLICATE of bug 812798
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 14:43 EDT by Jaroslav Franek
Modified: 2012-04-16 14:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 14:51:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2012-04-16 14:43:45 EDT
Description of problem:
Fresh install of Fedora 17 using network install DVD. In KDE it is impossible to  mount any USB NTFS disk or USB flash using the device notifier applet. 


Version-Release number of selected component (if applicable):
kernel-3.3.1-5.fc17.x86_64
ntfs-3g-2012.1.15-1.fc17.x86_64
selinux-policy-targeted-3.10.0-114.fc17.noarch
kde-workspace-4.8.2-3.fc17.x86_64
fuse-2.8.6-4.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start KDE session
2. Plug in any USB external NTFS device
3. Use device notifier applet to mount it

Actual results:
In device notifier: The device status is shown busy for few seconds. Later it is reported that the device could not be mounted (message from second attempt):
"Could not mount the following device: maxtor
The device is currently busy: A job is pending on /dev/sdh1"

/var/log/messages:
Apr 16 20:12:40 localhost kernel: [  108.089693] fuse init (API version 7.18)
Apr 16 20:12:40 localhost kernel: [  108.199776] SELinux: (dev fusectl, type fusectl) has no xattr support
Apr 16 20:12:40 localhost mount[1913]: mount: mount fusectl on /sys/fs/fuse/connections failed: Operation not supported
Apr 16 20:12:40 localhost systemd[1]: sys-fs-fuse-connections.mount mount process exited, code=exited status=32
Apr 16 20:12:40 localhost systemd[1]: Unit sys-fs-fuse-connections.mount entered failed state.

/media:
contains empty directories with disk names, e.g.
drwx------. 2 root    root       40 Apr 16 20:14 maxtor

Expected results:
Mount USB NTFS disks.

Additional info:
It is possible to mount USB devices with FAT16/32 filesystems.

There are few log lines in /var/log/messages that could be related

Apr 16 20:13:04 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:13:04 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:13:04 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:13:04 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:13:04 localhost automount[913]: lookup_mount: exports lookup failed for .directory
Apr 16 20:13:04 localhost automount[913]: key ".directory" not found in map source(s).
Apr 16 20:13:37 localhost automount[913]: key ".directory" not found in map source(s).
Apr 16 20:14:11 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:14:11 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:14:11 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:14:11 localhost automount[913]: create_client: hostname lookup failed: Name or service not known
Apr 16 20:14:11 localhost automount[913]: lookup_mount: exports lookup failed for .directory
Apr 16 20:14:11 localhost automount[913]: key ".directory" not found in map source(s).
Comment 1 Tom "spot" Callaway 2012-04-16 14:51:42 EDT

*** This bug has been marked as a duplicate of bug 812798 ***

Note You need to log in before you can comment on or make changes to this bug.