Bug 813066 - [as7] Expose multicast group/port of a ha-server as trait on server level
[as7] Expose multicast group/port of a ha-server as trait on server level
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity high (vote)
: ---
: RHQ 4.5.0
Assigned To: Armine Hovsepyan
Mike Foley
:
Depends On:
Blocks: as7-plugin 824958
  Show dependency treegraph
 
Reported: 2012-04-16 15:36 EDT by Heiko W. Rupp
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 824958 (view as bug list)
Environment:
Last Closed: 2013-08-31 05:56:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multicatAddress (199.19 KB, image/png)
2012-08-01 10:07 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Heiko W. Rupp 2012-04-16 15:36:54 EDT
In as4/5 there was the cluster partition name to "identify" clusters and to e.g. build dynagroups that contain all the members of one cluster. See e.g. https://issues.jboss.org/browse/AS7-4512
In AS7 this feature is deprecated so we need a replacement

One way to do that is to expose the multicast group/port as string trait on server level
(see also https://issues.jboss.org/browse/AS7-4512?focusedCommentId=12684672&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12684672 )
Comment 1 Charles Crouch 2012-05-18 06:23:21 EDT
Targetting this correctly.
Comment 2 Ian Springer 2012-05-23 21:36:36 EDT
This is done in master:

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=6eb0643

The new trait is called 'multicastAddress' and is defined on the Standalone Server and Managed Server types. A value will only be returned for the trait for a server that is in HA/cluster mode. The value format is "HOST:PORT" (e.g. "230.0.0.4:45688").
Comment 3 Ian Springer 2012-05-24 12:02:27 EDT
[master http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=b1e5c9b] excludes the 'multicastAddress' trait from the null-metric-values test for Managed Servers, since a null value is expected when the managed servers are not in HA mode, which is currently the case for the host controller instance used by our itests.
Comment 4 Armine Hovsepyan 2012-08-01 10:07:18 EDT
Created attachment 601749 [details]
multicatAddress

verified on both standalone and domain modes.

Note You need to log in before you can comment on or make changes to this bug.