This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 813119 - threading issues in reboot command error path
threading issues in reboot command error path
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
abrt_hash:4c4b70acd32df8c67318a1cba25...
:
: 742048 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 20:20 EDT by Fredrik Mikker
Modified: 2012-08-09 19:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (18.50 KB, text/plain)
2012-04-16 20:20 EDT, Fredrik Mikker
no flags Details
File: maps (81.63 KB, text/plain)
2012-04-16 20:20 EDT, Fredrik Mikker
no flags Details
File: backtrace (120.05 KB, text/plain)
2012-04-16 20:20 EDT, Fredrik Mikker
no flags Details

  None (edit)
Description Fredrik Mikker 2012-04-16 20:20:30 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager.py
crash_function: XQueryPointer
executable:     /usr/bin/python
kernel:         3.3.1-3.fc16.x86_64
pid:            26849
pwd:            /home/bol
reason:         Process /usr/bin/python was killed by signal 6 (SIGABRT)
time:           Tue 17 Apr 2012 02:00:12 AM CEST
uid:            1000
username:       bol
var_log_messages: Apr 17 02:00:13 zaphod abrt[32063]: Saved core dump of pid 26849 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-17-02:00:12-26849 (206262272 bytes)
xsession_errors: 

backtrace:      Text file, 122929 bytes
dso_list:       Text file, 18943 bytes
maps:           Text file, 83592 bytes

comment:
:I started a new installation of centos6 x86_64, the installation did not find any network device with network manager.
:I went to the configuration dialogue and changed the interface, got a question about the settings should be applied after a reboot.
:Used the menu-item in virt-manager to send a reboot, and this crash occured.

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=zaphod
:GIO_LAUNCHED_DESKTOP_FILE_PID=26846
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-6BNqye/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=01144dd2cdb9e934251c6cc100000006-1334449802.86149-399745999
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/tmp/keyring-6BNqye
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=bol
:SSH_AUTH_SOCK=/tmp/keyring-6BNqye/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1648,unix/unix:/tmp/.ICE-unix/1648
:USERNAME=bol
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/virt-manager.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/bol/.local/bin:/home/bol/bin
:MAIL=/var/spool/mail/bol
:_=/usr/bin/gnome-session
:QT_IM_MODULE=xim
:PWD=/home/bol
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1644
:KDE_IS_PRELINKED=1
:MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
:KDEDIRS=/usr
:LOADEDMODULES=
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/home/bol
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=bol
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-HealBNd4dK,guid=010f2d065694c46b03ed30b70000002a
:MODULESHOME=/usr/share/Modules
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/bol
:XAUTHORITY=/var/run/gdm/auth-for-bol-eUiur3/database
:'module=() {  eval `/usr/bin/modulecmd bash $*`\n}'

smolt_data:
:
:
:General
:=================================
:UUID: f344fe34-bee7-4131-bfaa-215f15514922
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6821.89
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 3401
:System Memory: 7964
:System Swap: 1999
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.1-3.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(6945:4224:6945:4224) pci, None, PCI/PCI, N/A
:(32902:256:4163:33869) pci, None, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(32902:7202:4163:33869) pci, i801_smbus, SERIAL, P8P67 Deluxe Motherboard
:(32902:7170:4163:33869) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:(32902:7238:4163:33869) pci, None, PCI/ISA, P8P67 Deluxe Motherboard
:(6987:37234:4163:33911) pci, ahci, STORAGE, N/A
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(32902:7188:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7190:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:9294:4163:33869) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7198:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 8
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33808) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(4318:3596:4163:33710) pci, snd_hda_intel, MULTIMEDIA, N/A
:(4318:4609:4163:33710) pci, nvidia, VIDEO, N/A
:(32902:7194:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 5112555 3191813 3140633 1286144 1050775 1050775
:/dev/sda3 /home ext4 4096 4096 15927189 6006123 5208351 3989504 3820119 3820119
:/dev/sdc1 WITHHELD ext4 4096 4096 731871253 202706138 166077825 183148544 182799066 182799066
:/dev/sdb1 WITHHELD btrfs 4096 4096 462778368 341818816 323586476 0 0 0
:
Comment 1 Fredrik Mikker 2012-04-16 20:20:36 EDT
Created attachment 577861 [details]
File: dso_list
Comment 2 Fredrik Mikker 2012-04-16 20:20:38 EDT
Created attachment 577862 [details]
File: maps
Comment 3 Fredrik Mikker 2012-04-16 20:20:41 EDT
Created attachment 577863 [details]
File: backtrace
Comment 4 Cole Robinson 2012-06-26 11:34:22 EDT
*** Bug 742048 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2012-07-08 14:48:40 EDT
This has been fixed upstream for a while actually
Comment 6 Fedora Update System 2012-07-09 18:03:17 EDT
virt-manager-0.9.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc17
Comment 7 Fedora Update System 2012-07-09 18:03:17 EDT
virt-manager-0.9.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc16
Comment 8 Fedora Update System 2012-07-10 16:51:35 EDT
Package virt-manager-0.9.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10462/virt-manager-0.9.3-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-29 17:23:23 EDT
virt-manager-0.9.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc17
Comment 10 Fedora Update System 2012-07-29 17:24:15 EDT
virt-manager-0.9.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc16
Comment 11 Fedora Update System 2012-08-09 19:03:05 EDT
virt-manager-0.9.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-08-09 19:24:05 EDT
virt-manager-0.9.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.