Bug 813219 - zsh gets in infinite loop when checking syntax
zsh gets in infinite loop when checking syntax
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: zsh (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Jan Kepler
: EasyFix, Patch
Depends On:
Blocks: 928849
  Show dependency treegraph
 
Reported: 2012-04-17 05:18 EDT by Sebastien Aime
Modified: 2013-09-30 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: zsh-4.2.6-9.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:20:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (375 bytes, patch)
2012-05-17 03:54 EDT, mahaveer darade
no flags Details | Diff

  None (edit)
Description Sebastien Aime 2012-04-17 05:18:56 EDT
With zsh on rhel5, running a syntax check against the script below never terminates whereas with rhel6 it does terminate.

---/---
#!/bin/zsh
while (( $X < $Y ))
do
done
---/---

rhel5> zsh -n loop.sh
loop.sh:2: bad math expression: operand expected at `<  '
loop.sh:2: bad math expression: operand expected at `<  '
loop.sh:2: bad math expression: operand expected at `<  '
...
(infinite loop)

rhel6> zsh -n loop.sh 
loop.sh:2: bad math expression: operand expected at `<  '

It appears that with zsh version 4.2.6 condition '(($X < $Y))' is true whereas it's false with version 4.3.10 from rhel6. As a result script never terminates when executed with rhel5 zsh.
Comment 1 mahaveer darade 2012-05-17 03:54:04 EDT
Created attachment 585136 [details]
proposed patch
Comment 2 RHEL Product and Program Management 2012-06-11 21:22:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 James Antill 2013-04-05 09:46:20 EDT
 The patch looks simple enough (I assume someone ported it, or just took it, from upstream?)
Comment 11 errata-xmlrpc 2013-09-30 19:20:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1337.html

Note You need to log in before you can comment on or make changes to this bug.