Bug 813244 - Should provide jenkins account related information when create a jenkins server in RestAPI
Should provide jenkins account related information when create a jenkins ser...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 06:09 EDT by yquan
Modified: 2015-05-14 21:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:46:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yquan 2012-04-17 06:09:48 EDT
Description of problem:
It doesn't provide any jenkins account related information  when create a jenkins server in website.

Version-Release number of selected component (if applicable):
devenv_1724

How reproducible:
Always

Steps to Reproduce:
1.Log on the website via the valid account.
2.Create a jenkins server.
  
Actual results:
There is no information related to jenkins account,such as account ,password.

Expected results:
It should provide the information like account,password.

Additional info:
Comment 1 Clayton Coleman 2012-04-20 13:35:25 EDT
Needs to come back from the rest API before we can show it.  This sounds like a potentially blocking problem for this sprint - if we can't get to it we should disable jenkins again.
Comment 2 Rajat Chopra 2012-04-25 16:53:00 EDT
Fixed with rev#cb6b40d0d9aa23464cd1b9775fbab8fc8da8b1c1
Comment 3 Xiaoli Tian 2012-04-26 05:13:56 EDT
Verified it on devenv-stage_176
Since jenkins is disabled in web for now, checked it in rest api.

#curl -k -H "Accept: application/xml" --user "xtian+t91@redhat.com:1"  https://ec2-23-22-7-231.compute-1.amazonaws.com/broker/rest/domains/domx011/applications -d name=jenkinsserver -d cartridge=jenkins-1.4 -X POST
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>created</status>
  <type>application</type>
  <messages>
    <message>
      <text>Application jenkinsserver was created.</text>
      <severity>info</severity>
      <exit-code nil="true"></exit-code>
      <field nil="true"></field>
    </message>
    <message>
      <text>
Jenkins created successfully.  Please make note of these credentials:

   User: admin
   Password: E4cmZ-Tj9-R6

Note:  You can change your password at: https://jenkinsserver-domx011.dev.rhcloud.com/me/configure

</text>
      <severity>info</severity>
      <exit-code>0</exit-code>
      <field>result</field>
    </message>
  </messages>

Note You need to log in before you can comment on or make changes to this bug.