Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 813262 - errors at shutdown from dracut
Summary: errors at shutdown from dracut
Keywords:
Status: CLOSED DUPLICATE of bug 831634
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-17 10:58 UTC by Need Real Name
Modified: 2012-06-29 14:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-29 14:10:32 UTC
Type: Bug


Attachments (Terms of Use)
lsinitrd output (169.29 KB, text/plain)
2012-04-17 14:00 UTC, Need Real Name
no flags Details

Description Need Real Name 2012-04-17 10:58:05 UTC
Lots of missing binaries in 30{dm,md}-shutdown.sh:

dmsetup not found
mdadm not found
cat not found
reboot not found
kbd_mode not found
stty not found
setfont not found

Dropping to debug shell.

Comment 1 Harald Hoyer 2012-04-17 11:09:49 UTC
(In reply to comment #0)
> Lots of missing binaries in 30{dm,md}-shutdown.sh:
> 
> dmsetup not found
> mdadm not found
> cat not found
> reboot not found
> kbd_mode not found
> stty not found
> setfont not found
> 
> Dropping to debug shell.

which dracut version?

what is your grub.cfg entry of the booted kernel?

what is the output of:

# lsinitrd /boot/initramfs-$(uname -r).img

Comment 2 Need Real Name 2012-04-17 13:59:38 UTC
Giving for current version of kernel which I installed since this bug report.

(In reply to comment #1)
> which dracut version?

dracut-018-12.git20120416.fc17.noarch
 
> what is your grub.cfg entry of the booted kernel?

$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.3.2-1.fc17.x86_64 root=/dev/mapper/vg_munich-lv_root ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=en_GB.UTF-8 KEYTABLE=de-latin1-nodeadkeys

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.3.2-1.fc17.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
        savedefault
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='(hd0,msdos1)'
        search --no-floppy --fs-uuid --set=root 4baec165-a740-489c-bd52-471023b2f27a
        echo 'Loading Fedora (3.3.2-1.fc17.x86_64)'
        linux   /vmlinuz-3.3.2-1.fc17.x86_64 root=/dev/mapper/vg_munich-lv_root ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=en_GB.UTF-8 KEYTABLE=de-l
atin1-nodeadkeys
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.3.2-1.fc17.x86_64.img
}

> what is the output of:
> 
> # lsinitrd /boot/initramfs-$(uname -r).img

Will attach.

Comment 3 Need Real Name 2012-04-17 14:00:10 UTC
Created attachment 578042 [details]
lsinitrd output

Comment 4 Lennart Poettering 2012-04-18 11:08:01 UTC
Could you please create the following file /usr/lib/systemd/system-shutdown/dmesg:

#!/bin/sh
mount / -orw,remount
dmesg > /dmesg.save
mount / -oro,remount

And then chmod +x it. Then, reboot with "systemd.log_level=debug systemd.log_target=kmsg" on the kernel cmdline, and shutdown. On next reboot please provide us with the contents of /dmesg.save.

Comment 5 Harald Hoyer 2012-04-18 11:31:14 UTC
oh.. and please test, if dracut-018-22.git20120418.fc18 fixes the issue.

Comment 6 Need Real Name 2012-04-18 11:40:04 UTC
Hi,

Since comment 3, I have been able to reboot without problems.

I had been getting a lot of selinux errors since upgrading to F17a and so I've run a relabel since filing the bug report. I don't know whether this is relevant.

Since I can no longer reproduce the problem I reported, would it still make sense to carry out the steps in comments 4 and 5?

Thanks.

Comment 7 antonio montagnani 2012-04-28 17:16:51 UTC
it happens also here after upgrading from F16 and fully updating my system

Comment 8 antonio montagnani 2012-04-28 17:21:16 UTC
it happens also here after upgrading from F16 and fully updating my system

Comment 9 Harald Hoyer 2012-05-02 11:11:54 UTC
(In reply to comment #8)
> it happens also here after upgrading from F16 and fully updating my system

so, open a new bug for F16 and give the infos requested in previous comments, please.

Comment 10 antonio montagnani 2012-05-02 12:16:48 UTC
after upgrading my F17 Beta system, these warnings disappeared...

I think that tests are not necessary any longer

Comment 11 Vadim 2012-05-15 06:09:03 UTC
After updating my Fedora 16 to 17, I have the same problem with shutdown my notebook. What kind of logs and other information do I make to solve this problem?

Comment 12 Harald Hoyer 2012-05-29 11:49:38 UTC
(In reply to comment #11)
> After updating my Fedora 16 to 17, I have the same problem with shutdown my
> notebook. What kind of logs and other information do I make to solve this
> problem?

what is the output of:

# lsinitrd /boot/initramfs-$(uname -r).img

Comment 13 Harald Hoyer 2012-05-29 13:17:24 UTC
and:

# find /run/initramfs

Comment 14 Vadim 2012-05-29 17:16:18 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > After updating my Fedora 16 to 17, I have the same problem with shutdown my
> > notebook. What kind of logs and other information do I make to solve this
> > problem?
> 
> what is the output of:
> 
> # lsinitrd /boot/initramfs-$(uname -r).img

Sorry guys, but I solved the problem. The problem was in the latest kernel, at the time of my upgrade (3.3.5x to f16 vs 3.3.4x in f17). After installing the native kernel on Fedora 17 - my laptop normal reboot/off.

Comment 15 Hin-Tak Leung 2012-05-31 16:28:33 UTC
The F17 kernel did not work (failed to find root file system, some error about device mapper), and is currently booting the last f16 kernel with the rest of F17.

Both are 3.3.7-1, so that's curious. Also saw the kernel panic on shutdown, lots of udev stuff missing, etc... quite ugly...

Comment 16 Cole Robinson 2012-06-29 14:10:32 UTC
Pretty sure the initial report is the same as 831634, so duping to that. Please reopen if I'm wrong

*** This bug has been marked as a duplicate of bug 831634 ***


Note You need to log in before you can comment on or make changes to this bug.