Bug 813271 - intermittent appliance boot failures (divide_error)
intermittent appliance boot failures (divide_error)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On: 813413 814231 1005011
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 07:32 EDT by Pádraig Brady
Modified: 2016-01-04 09:43 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 813413 (view as bug list)
Environment:
Last Closed: 2012-11-26 18:37:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guestmount debug output (14.57 KB, text/plain)
2012-04-17 07:34 EDT, Pádraig Brady
no flags Details
guestfish messages from failed boot (132.58 KB, text/plain)
2012-04-17 13:06 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Pádraig Brady 2012-04-17 07:32:36 EDT
libguestfs-1.16.18-2.el6.x86_64

Easy to reproduce here.
Just boot a VM with:

http://download.devel.redhat.com/rel-eng/RHEL-6-Alpha-2.0/6.3/Live/RHEL6.3-20120329.0-Workstation-x86_64-Live.iso
      https://bugzilla.redhat.com/show_bug.cgi?id=808935 # to fix anaconda bug
And these repos:
    http://download.devel.redhat.com/rel-eng/RHEL-6-Alpha-2.0/6.3/Workstation/x86_64/os/
    http://people.redhat.com/~rjones/libguestfs-RHEL-6.3-preview/

truncate -s 100MB file.t
mkfs.ext2 -F file.t
while true; do date; LIBGUESTFS_DEBUG=1 guestmount -m /dev/sda -a file.t t >>gmount.out 2>&1 && { cd t; cd ..; umount t; } || echo "mount failed"; done

gmount.out is attached
Comment 1 Pádraig Brady 2012-04-17 07:34:16 EDT
Created attachment 578003 [details]
guestmount debug output
Comment 3 Richard W.M. Jones 2012-04-17 08:13:54 EDT
Does this fail?

while guestfish -a /dev/null run -v > /tmp/fish.out 2>&1 ; do echo -n . ; done
Comment 4 Richard W.M. Jones 2012-04-17 10:38:09 EDT
(In reply to comment #3)
> Does this fail?
> 
> while guestfish -a /dev/null run -v > /tmp/fish.out 2>&1 ; do echo -n . ; done

In answer, Pádraig tried it and yes it does fail after a few
iterations ("fewer than 6" according to Pádraig).

I tried it on 6.2 (but on baremetal) and it ran for hundreds of
iterations, so this could be a kernel regression, but I still
need to check I can reproduce the issue on 6.3 beta 1 + baremetal.
Comment 5 Richard W.M. Jones 2012-04-17 13:06:08 EDT
Created attachment 578109 [details]
guestfish messages from failed boot

Seems to only happen in a nested VM, and rather easy to trigger.

libguestfs-tools-c-1.16.18-2.el6.x86_64
qemu-kvm-0.12.1.2-2.272.el6.x86_64
kernel 2.6.32-262.el6.x86_64
Comment 6 RHEL Product and Program Management 2012-05-03 01:16:02 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 Richard W.M. Jones 2012-09-28 08:33:30 EDT
Still seeing this one with:
kernel-2.6.32-309.el6.x86_64
qemu-kvm-0.12.1.2-2.316.el6.x86_64
although it took me 200 iterations to hit it.

I'm going to try adding noapic to the command line.
Comment 8 Richard W.M. Jones 2012-09-28 09:13:29 EDT
Crashes with noapic too, in a different way!
Comment 9 Richard W.M. Jones 2012-10-11 05:15:33 EDT
As I don't have a way to fix this, or even to reproduce
it reliably, and the evidence points to an obscure timing
issue within qemu, I'm afraid all I can do is defer this
to RHEL 6.5 and reassign it to qemu.
Comment 10 Dor Laor 2012-11-13 11:49:25 EST
Is that important enough not to close it?
Comment 11 Ademar Reis 2012-11-26 18:37:30 EST
(In reply to comment #10)
> Is that important enough not to close it?

+1

I'm closing it, please reopen if you believe it's actually important and can be reproduced in a non-nested environment.

Note You need to log in before you can comment on or make changes to this bug.