Bug 813277 - \s*\R does not match
\s*\R does not match
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcre (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Pisar
Lukas Zachar
https://lists.exim.org/lurker/message...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 07:48 EDT by Petr Pisar
Modified: 2014-06-12 04:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: pcre-8.21-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 813237
Environment:
Last Closed: 2014-06-12 04:41:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-04-17 07:48:31 EDT
+++ This bug was initially created as a clone of Bug #813237 +++

/\s*\R/
\x20\x0a
\x20\x0d
\x20\x0d\x0a

This should not match in all cases, but it does not.

This is regression since pcre-8.02. All Fedoras affected.
-----

RHEL-7 (pcre-tools-8.21-2.el7.1.x86_64) affected too.

Note You need to log in before you can comment on or make changes to this bug.